Forum

Some fonts not working with DX11

Hi,

I encountered a strange issue: some fonts are not rendered correctly in DX11. It’s not only, that bold and italic versions are not working but also the font itself is substituted by some standard one (but not sure which). Installed whole font family (with -bold, -italic, -regular, … fonts).

DX9 is working properly. Is there some fix or workaround for that? Would be very thankful for every hint, even dirty (but easy) solutions are welcome ;)

Thanks a lot!

Please, don’t let us guess which are these fonts, tell us.
It could be useful to know your graphic card model.
And if drivers are up-to-date.
You should post a screenshot, so that is possible to understand better the issue.
You should post a patch.
Maybe this is of some help: https://discourse.vvvv.org/t/12149

Thx for your reply. Here you got a screenshot (font is different because I don’t have the font here) but there is really no magic. The font family is “Interstate” (OTF, commercial) and also read about another font not working (https://dl.dropboxusercontent.com/u/23860719/Glober%20Family.zip) but didn’t test. “Interstate” works well in other applications but not in vvvv(_45beta33.3_x64 which is my version). Gfx card is GeForce GTX680.

vux already answered the following on github issue (https://github.com/mrvux/dx11-vvvv/issues/123) but I see no solution inside:

I only needed a quick solution or workaround if somebody already encountered that problem. Would be very important to render that special. Already tried rendering a DX9 texture, convert it to DX11 and draw on quad which kind of worked but only if renderer focused, otherwise node wasn’t evaluated (and is by the way no nice solution) ;)

For workarounds have a look here: https://discourse.vvvv.org/t/12149