Forum

SkiaRenderer not working since 3.0

Hi!

Since the 3.0 preview and the move to Stride, I can’t use Skia nodes: the Stride SkiaRenderer is not working. Even through its input preview is showing what is expected, its output is blank. Observed this with any kind of Skia Layer type node as input. Stopping and Running the patch again does not help.

OS: Windows 10
Graphics card: Radeon RX 560X (latest drivers)
vvvv version used: vvvv gamma 2020.3.0-0042-g1a9a5c158d preview

1 Like

Did you add dependencies, they were removed as default

The Skia dependency is added, yes.

Yes, I am facing the same bug - thanks for describing it!

OS: Windows 10
Graphics card: Radeon R7 200 (latest drivers)
vvvv version used: vvvv gamma 2020.3.0-0042-g1a9a5c158d preview

Works here on Intel HD620, NVidia RTX 2080 and GTX 1080, tested with latest drivers.
Maybe try the Stride SkiaRenderer and see if it works for you.

The Stride SkiaRenderer seems to be the source of the issue. Here are a few screenshots to demonstrate.

  1. Patch, Renderer and RenderWindow
  2. The input preview on the SkiaRenderer (looks good):
  3. The output preview on the SkiaRenderer (looks bad):

Ah ok got you wrong the first time, thought you were refering to the “plain” skia renderer.

interesting, could this be a problem with AMD Radeon drivers? maybe AMD is missing some interop functionaly that the other vendors have, or they use other methods to provide similar functionality.

Can you check whether the OpenGL extension WGL_NV_DX_interop2 is available on your graphics card?

grafik

Maybe this is related: https://community.amd.com/message/2893683
It’s supposed to be fixed, but who knows …

@Elias Seems like WGL_NV_DX_interop2 is present.

image

same here:
wgl_info

Related to Windows Server 2019 - can't open VL document on 50beta39 ?

We had a similiar issue on a machine with two graphic cards. The SkiaRenderer chose a different one and the internal resource sharing didn’t work. So if you have two graphic cards in your machine, try to disable one and see if that solves it.

Interesting - you still have that machine? Indeed we need to create a GL context with a dummy window and then later make the dx11 device available to that context using before mentioned wgl interop extension. Maybe if for some reason that context is on a different device than the directx context things don’t work.

Only one graphics card here.

Actually, it turns out I do have 2 graphics cards. Both AMD. One integrated, and a “proper” one. My mistake.
But I tried everything I could find, and the problem persists. I tried:

  • Disabling a graphics card in the device manager (did that with both).
  • Changing individual performance settings for vvvv in the Windows 10 graphics settings.

confirmed as dual-gpu issue on my side:
geforce 980 (with all the displays) + 1080 (no displays, used only for python/neuralnets renderings).
skia + stride works only when 1080 is disabled.

is it expected to be fixed?

When trying to patch along to the Reactive Patching workshop from Node I discovered SkiaRenderer (trying to render the ISS data text output in Stride renderer) doesn’t seem to work for me either on a super modern Surface Pro 2 with intel graphics.

Rendering other geometry in the Stride renderer works and if I connect the Text Layer to a Skia renderer the text renders fine.

bild

(edit: running vvvv gamma 2020.3.0-0042-g1a9a5c158d preview seems like there are more recent versions I could try)

@eps @mburk I assume you both were on desktop machines?

@beyon The GL version looks dated to me - compare it to my screenshot further up. Is there a driver update available maybe? Intel HD 4400 is from around 2012, while the HD 530 is from ~2015 - these three years could make quite the difference I fear :/