Shader changes in beta 13?

I’m really excited by some of the fixes in v13, but I’m having a bit of trouble porting my patches over to the new version.

Specifically a lot of my shaders that worked in v12, no longer compile, and only the generic shader pins show up…
The built in shaders seem to work fine though.

When I try to instantiate a shader with the TTY open, I get the ambiguous error: [ custom settings ]( custom settings ) couldn’t be created because of unknown reasons.

Are there some changes I need to make to my shaders to make them v13 compatable?

Oops, my bad. I forgot to copy over Transforms.fxh.

Now that I’ve done that it works great. Thanks!

(though I noticed there’s still the little problem in the fx editor where when you use the scrollwheel while selecting text, vvvv crashes)

i remember we had the editor+textselect+scrollwheel=crash discussion earlier. still i cannot reproduce it. can you describe in detail what you do to make vvvv crash?

Sure, open up a new patch and create a Template EX9 effect.
Right click on it to open up the editor.
Select some text in the editor using the left mouse button and dragging (do not release the left mouse button).
Now use the mouse wheel to scroll up or down.
After one or two clicks of the mouse wheel, VVVV crashes silently for me.

It only exhibits this behaviour with the left mouse button depressed, not with any other button combination.

I did a bit of testing and have noticed that if the editor doesn’t crash on the first click of the mouse wheel, it scrolls to the very bottom of the editor (it doesn’t do this without the left button pressed). After that if I continue to scroll (in either direction) it crashes, but if I release the left mouse button, normal operation resumes.

Judging by the fact that it scrolls right to the bottom, my best guess would be that maybe VVVV is trying to do a selection beyond the range of the text box and running into some overflow condition?

I hope this helps, cheers!

right, funy enough it only happens on one of my pcs, but not the other. i think i fixed it. thanks for pointing it out.

Great! Good to hear, I get burned by that bug about twice a month.

I think it may be differences in the ways different mice send messages, as it happens with all the external mice of mine, but not with my Macbook pro trackpad.