Segment bug?

I noticed a strange behaviour of the Segment (EX9.Geometry 2d) node in version 45beta24.1. I don’t know if it happens only on my computer. If I connect two renderers and put one renderer to the second monitor and try to change one of the pins, it changes only one of the two renderer screens.

I attached a file for explanation.

segment bug.v4p (4.5 kB)

i did’t swiched right now on beta45, so can’t seems to check it
can sugest you try switch it on sphere and check agin

here some module i just made might you can use it for a replacement of segment.

Segment (EX9.Geometry) unfinished.v4p (18.7 kB)

Hey Antokhio!

Nice patch! Thank you. I’ll watch it later more accurately. I tried it with other geometries and there doesn’t appear the problem, just only with the Segment (EX9.Geometry 2d) node.


I tried it with vvvv version 40 beta 23 and there is the same problem.
Please could someone try if it does the same on your computer?

I found a workaround for the Segment node bug. If you split up the Segment in Mesh and Vertexbuffer and rejoin it, then the problem disappears…

I don’t know why, but it works! :)

segment bug workaround.v4p (8.5 kB)