Salad bowl projection

well, there is one more thing :)

we almost got the dome projection working. of course there are some difficulties and ideas to solve them. gonna post a patch later. here is a picture of the almost working system…

sbp01.jpg (8.9 kB)

alright, here is the problem…we need to put the output of the cam-rig to another renderer as texture and for the first time i realised how bad the dx9texture (respektive directx) does this job.

or maybe, i don’t understand the concept of the backbuffer. basically we need to have the scene as identical as possible as texture within the second renderer. there we do some additional distortion which makes pixelated picture even worse… any ideas,guys ?

refer to patch…

some notes regarding the dome projection: we have the whole boygrouping successfully running, 5 out of 6 projectors work seemless and the distortion is perfect…when u stand on a chair ;). we are going to change the grids to a lower cam position and fix the top grid. but so far, it looks very good…apart from nasty pixelation when using thin lines.

next thing to come is installing the videoplayer patch and work out how motion-tracking data is distrubuted to the client machines. (4.3 kB)

hi u7angel.

i think your texture is messed up because the the generated texture and size of your output renderer doesnt match. if you have a look at the dx9texture node via inspektor you can see that you can enter a specific size of the texture. you can also enable those texture size params as inlet. now you can connect the backbuffer size outlets of your target renderer with the size inlets of dx9 texture and your texture is always in the same size as your target renderer. play also around with the filter node…

check the patch. (5.0 kB)

he thanks , the filter node is new to me…
apart from that we fixed the quality with simply putting backbuffer and dx9 texture to 2048x2048…the card seems to be ok with it performance wise…and wireframe mode is just some special case which looks slightly nasty, not enough pixels to interpolate

i remember one thread talking about antialiasing and writer(NRT)…that antialiasing is not being processed for textures…this is somehow part of the problem of the messy wireframe picture i guess…or am i wrong?

i’d say you only need to set the dx9textures size to 2048x2048 and leave the renderers backbuffer alone. this is somehow doppeltgemoppelt. (otherwise you have a reason why you’d set the renderers backbuffersize too).

and yes. dx9textures can not be antialiased (=multisampled). you can render twice as big and scale down the texture to get some kind of line smoothing.

my last post here is old: meanwhile dx9texture is antialiased if the connected renderer has antialiasing set. no more need for the workaround mentioned above.

i just tested it and yeah…it does work. quite cool for writer(NRT) rendering.