Forum

S+H, or FrameDelay, or both, or what ?... Incomprehensible bug

Hello,

Please tell me I’m not crazy.
I lost HOURS on this problem, and still no solution.

I wanted a patch which can store changes made on a spread, so it uses SetSlice in a S+H/FrameDelay loop.
At the first update of values after initialization, it fails : all values which have to be updated (according to wanted indices) are duplicated from first one. If I retry, it works. Or if I initialize again then I update, it works.
When I want to debug and put a S+H set at the moment of the update, it works ! Why ??
When I set to the “Set on Create” of the S+H of the loop, it works.
When I simply open the subpatch, it works !?!
Why it doesn’t work when it doesn’t work ???

I made this example to show you this problem (with clear instructions inside it, I hope), but I have it too in a bigger patch using this “Update” patch, and it doesn’t work even if the “Set on Create” of the S+H of the loop is set to 1.

Any help or advice would be very appreciable.

Matthieu

PS : I’m using 45beta25.0

StrangeBug.zip (3.7 kB)

As my last shot, I decided to try and make a plugin to replace my “Update” module. After 1 hour of learning how to write Dynamic Plugins, I finally have a little plugin maybe not perfectly written but working perfectly well for what I wanted.

Due to the number of strange effects and headaches I had with framedelay (my first suspect), I think I will rather use C# every time it is possible.

But still interested to know what happens with this problem.

StringUpdateSpread.zip (31.6 kB)

Hi Matthieu

Just had a little look, and it is a bit unclear to me what it is you try to achieve.

what is the wanted behaviour?

Which changes is it that you want to store?

Besides that, I can recommend upgrading to beta25.1¨

-sunep

Hello,

Thank you for your response.

The wanted behaviour is basic :

  • store an initial spread (bang to “Initialize” stores “Default”)
  • be able to update some slices (bang to “Update” replaces values at indices of “Index” by values of “Input”) several times (so be able to store updates)

Yes I tried beta25.1, but it is unusable for me, a real nightmare : unable to add any new module I write, the scan of externals seems to not work. And the “Save as” still doesn’t work (the resulting patch can never be seen by vvvv). I really miss beta23 for that feature.
But maybe there is something I don’t know about all that…

Matthieu

PS : I attach an updated version of my plugin (correction of a bug), for other people who would need it

StringUpdateSpread2.zip (31.7 kB)

Haven’t properly read your post but is this what you need ? - http://www.vvvv.org/contribution/s%20h-%28in-patch-in-file%29

Alt-R to open root, and be sure to READ info inside to add your modules
nodes and paths 25.1

@mrboni
No I think it is not what I needed. Plus I don’t really understand how this module works. But thank you.

@antokhio
Thank you very much, I didn’t know at all about this new feature and I could not find that by myself since I really never use or open the root patch.
I will retry beta25.1, but as I’m used to have my modules in a personnal directory in the “modules” directory of vvvv, it should already have worked last time.

Obviously something I don’t get.
I have uninstalled 45beta25, and installed 45beta25.1.
I tried to move all my modules, plugins and effects in a directory outside the vvvv directory. I filled fields in the root patch, all my modules are seen.
But like I said when I create a new module, it is not listed in the NodeBrowser, even after Alt+E or restarting vvvv. So release unusable. Don’t know what to do !?!

checkout the https://discourse.vvvv.org/ Dictionary Plugin?

@initial bug:

thanks for your detailed report! solved a subtle chaching issue with setslice for > beta25.1

@module not listed:
make sure, that one of the following directories is specified in your root:

  • either the exact directory where your new module is located in
  • or a master directory for your own nodes in which there is a “modules” folder. in this case your module can be in any subfolder of the “modules” folder.

please report again, if it is still not working.

@eno : Thank you, maybe I’ll use this plugin for other things

@gregsn : Thank you for correcting an issue in SetSlice.
About the module not listed, it is still not working, I really don’t understand how other people can use the release.

I tried to put new modules directly in C:\vvvv\vvvv_45beta25.1\modules, or in
C:\vvvv\vvvv_45beta25.1\modules\mymodules\Animation for example, or in C:\vvvv\vvvv_45beta25.1\mywork\modules\Animation (for example again) after declaring the path C:\vvvv\vvvv_45beta25.1\mywork\ in root patch, always same strange result : sometimes the new module is not seen at all in modules, sometimes it is seen, but tagged “t” in the node browser (and not “m”) and not anymore after a new vvvv session. And when I create an other new module in a new session, the previous new module is seen again, tagged “t”. And the next session, nothing until a new creation, etc etc.

I really would like to use 25.1, because in 25 the code editor is a punishment to use (because of the Ctrl+C/V bug).
Saying that, I see that the zoom bug (zoom when closing a {} ) is still there in 25.1, it’s annoying…

zoom bug (zoom when closing a {} ) fixed for betas>25.1

module not listed bug fixed for beta>25.1