Renderer (GDI) fullscreen-problems in beta10

Renderer (GDI) shows very strange and different behaviors when trying to switch to fullscreen depending on the state the renderer was in before.

Renderer (GDI) windowed when trying to switch to fullscreen:
Renderer “looses frame” and popps up in the upper left corner of the screen the windowed renderer was positioned.
Renderer does not go fullscreend but opens in exactly the size it had in windowed mode.
Changing Backbuffer Width and Height does not have any effect on the size in “fullscreen”-mode.

Renderer (GDI) boxed when trying to switch to fullscreen:
Renderer goes fullscreen on screen #1 independent of whether patch runs on screen #1 or #2
so - no way to bring the Renderer (GDI) to fullscreen on #2

Renderer (GDI) in “Hide Mode” when trying to switch to fullscreen:
Renderer goes fullscreen on the screen where the last position of the Renderer (GDI) Window was in Window mode !?
If you switch to fullscreen you see the “Renderer (GDI) Window in Window mode” for a short moment before it goes to fullscreen.

All above described effects are the same when using the fullscreen-pin or ALT-Enter.


i also observe that the gdi renderer sometime seems to loose its position in box mode…

hmm schade … no change here with beta11.

For the problem Sebastian mentioned that a boxed gdi renderer is loosing its position and moving to the upper right corner when opening a patch there is a workaround (not nice but simple):
If connecting an “OnOpen” to the FullscreenPin of the renderer the boxed GDI-Renderer shows up on the correct position. If using more than one boxed GDI-Renderer this “Fullscreen-Bang” must be delayed with frame delay for every additional renderer.


halo ms.

sory for being late on this one. strange thing i don’t see your problems. the only thing i can reproduce is the boxed-renderer always going fullscreen on the first monitor, which is not so cool. when hidden it somehow makes sense to go fullscreen to the last monitor the window was on.

anyways i get a working gdi-fullscreen starting from any other mode. so what? i tested on an ati-card. in dualheadmode. not spanmode. maybe spanmode causes them troubles? can you try different setups/cards?

nvidia and ati have those strange tools that somehow interfere with windowpositioning…do you have one of those activated?

@oschatz. if i remember correctly that is one of our first bugs and is related to an addflow-bug…never found it soo nasty to dig into it again. but we should log it…

Hi Joreg,

i tried the behaviour of the GDI-renderer on some different cards and systems and found out that it is exactly the same on all the cards I tested (ATI: Radeon9800, X800; nvidia: 5600, 6600, 6800).

Here the results in Detail:

  • The “oschatz-bug”
    If opening a patch with a GDI-renderer in boxed mode the boxed renderer shows up grey with inwritten “Renderer” and the content of the renderer is displaced to the upper left corner of the vvvv-window. This is 100% reproducable on all systems i tested and can be corrected by moving or scaling the boxed renderer or by banging the fullscreen pin of the renderer.

  • The fullscreen bug or (perhaps better) -strangeness
    You are right - every fullscreen-scenario for the GDI-renderer can be achieved, but as there are some dependencies between the “ALT + 1,2,3,Enter” Modes and the use of the fullscreen pin it is really hard to predict what behaviour the use of the fullscreen pin will have.

fullscreen-pin from windowed mode:
If you set the fullscreen pin when GDI-Renderer is in windowed mode (ALT+1) the renderer is not going fullscreen but is shown as “borderless window” at the top left corner of the monitor where the windowed render has been before. The size of this “borderless window” is alsways the size of the renderer in windowed mode - changing backbuffer width and height does not change this size.

fullscreen-pin from boxed mode:
If you set the fullscreen pin when GDI-Renderer is in boxed mode (ALT+2) the renderer goes fullscreen on monitor 1. It is always monitor 1, the position of the patchwindow or the previous position of the renderer in windowed mode has no effect.

fullscreen-pin from hidden mode:
If you set the fullscreen pin when GDI-Renderer is in hidden mode (ALT+3) the renderer goes fullscreen on the monitor where the renderer was in windowed mode before. With this method you are able to show a fullscreen GDI-renderer on Monitor 2 !

… so, to summarize:
Everything is possible, but i think the way to achive it is not very logical, not easy to foresee and inconsistent.
My feeling is that it might be good to reconsider the coexistence of “ALT + 1,2,3,Enter” and the fullscreen pin as these two will most likely always influence each other. What about loosing the “ALT + 1,2,3,Enter - function” and changing the fullscreen pin to an enumeration “windowed / boxed / hidden / fullscreen” ?
This could be the same for all renderers !?
What I also like about this idea is that you will no longer have this kind of hidden “ALT + 1,2,3,Enter - setting”, that can not be retrieved or changed within the patch itself !?

… long text … what do you think ?