Forum

Render clear pin set to 0 & DX textur

hello all,

inspired be onoxo i did a few experiments with the render clear pin (set to 0) and transformations …

but everytime when i tried to save my “artworks” via a DX texture or something like writer NRT, the saved file isn’t the same like what i see in the render … the only way to get a proper file outta the render was pressing Strg + 2 and everything was fine.

*so means that, if render clear pin is set to 0, DX texture stops to work correctly?
*is there a way to trigger Strg + 2 from a VVVV patch?

thanks bene

did you try the keyboard node sending CTRL 2 ?

damn. i just accidentally deleted MrBenefits answer stating that indeed sending 2 to a Keyboard (System Globals) input triggers the shortcut for "screenshot"

but still he wanted to know whats up with the dx9-texture when clear on the renderer =0

ok. i also had the same problem with missing trails on the dx9-texture when clear was off on the renderer.

for performance reasons i tried to set width/height to 2048/2048 on the dx9texture only the moment i wanted to write the file to disk. when i did so the trails where missing. obviously. because the trails also need to be renderer already at full size. so there is no workaround for the case where you want the trails.

but version >11.1 includes an extra pin on the writer named “Only Render On Save” which lets you at least optimize the case if you don’t need the trails.