Region won't output incoming spread

hi all,

just had a weird problem. Couldn’t figure out why my region did not output my spread. Created multiple regions, some with “surround” and some from the node browser. None of them worked.

The fifth or sixth region suddenly worked. Unable to reproduce, but maybe something helpful for you within the file for you guys?

VL 2020.2.3

vlVideoplayer.vl (13.6 KB)

Could reproduce but I can’t understand. Substring did throw an error when I used getslice and tried the Filename->Substring combo, I got an error at first, that I can’t reproduce at the moment, and then it ran smoothly, but with the for region still failing to output any strings.
Good catch

Strange one indeed. Looking at the XML of the foreach region (Ctrl+C in patch, Ctrl+V in any text editor) it seems there’s a Keep pin we don’t see in the UI. Re-creating that pin and the loop starts working again. The system should probably get rid of such artifacts. Thanks for pointing it out.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.