Forum

Red underlayed Node problem

Hello guys,

i’m new in v4 and got a little problems with the nodes. I’m using a Win7 x64 OS and the latest v4 x64 and teaching me v4 with Prototyping Interfaces. As you can see in the image I have red underlayed nodes. If i search them and ad them to the patch they will still work but still red underlayed. in the “camera (transform softimage”)node there are some new red underlayed nodes. v4 is telling me “mouse (system global legacy)is missing. id106”. I can’t find any solution for this problem.

How can i fix that?

Salute

stick win 32bit unless you have more than 2gb to store in memory…
… so reinstall vvvv45beta31 x86 (32 bit) following the procedure:

downloads

install core and addons pack 32 bit…

Hm, this works not for me. I have the same problems now on a Win8 machine with latest v4 x86 already installed and run on Win7 compatibility then I start it as admin. The addons are in the correct folders. The kinect patches for openNI and microsoft can be found, if I add them they are a few seconds grey and switch then to red underlayed. A lot of the patches can be found twice if I search for them.

well, then it seems you’re doing something wrong.
forget about compatibility modes and running as admin.

all you have to do is:

  • download and extract vvvv
  • download and extract the suitable (x86 vs 64) addonpack an place it so that the \addonpack directory lies next to \girlpower inside your \vvvvXY directory
  • run crack.exe

if kinect nodes come up gray but then turn red when you hover one of its outputs there may be a problem with their drivers. make sure you get exactly the drivers listed on the kinect page.

So I downloadet it again, extract it, placed the addonpack folder next to girlpower run the crack.exe start v4 as admin and get the same result. the drivers for ms kinect and openNI seem to be ok.

Use 7zip or winrar to unpack the archives, don’t use the built in windows .zip reader

and don’t run vvvv as admin.
(while this will not cause a problem it simply is not necessary)

7zip brings nothing, same result as before.

does it help if you install vvvv to a subfolder of your user account? e.g. C:\Users\YOURNAME\vvvv ?

No result with the subfolder. After using winrar vvvv produces a system failure on startup of the vvvv.exe

it seems that the kinect is the only one that caused problems. I follow the path of vvvv in the vvvv/addons/lib/nodes/plugins but there’s no kinect.v4p or kinect_help.v4p. could this be the problem why the node doesn’t work for me? On my old machine I can found at least the kinect_help file.

Edit: I found the helpfile in the addonpack. Any other Ideas what it could be? Whats with my Hardware/Software, could that be a cause for having trouble with the kinect node?

I’m using a Win8 (is there any known problems with programms like skype, Adobe CS, etc. and vvvv known?)

Hardware: Core i7 4700, geforce gt750m, 8gb ram

as mentioned in missing in 64bit builds kinect (openni) nodes are only available with the x86 build. Kinect (Devices Microsoft) is available with the x64 build though?

nope! I’m using the x86 build.

Are you also using the 32bit addons, or the 64bit ones?

no. both are x86

now exactly what is your problem again?
please attach a patch you’re opening and describe the problem you see with it.

My problem is the kinect (devices microsoft) node. It’s the only one who won’t work. The rest of the red underlayed nodes still work now.

Kinect (Devices Microsoft) help.v4p (11.3 kB)

ok and at the same time you say “the drivers for ms kinect and openNI seem to be ok.” how are you testing that?

for the openNI you have a Testtool that works for me. I installed and uninstalled the drivers for ms a lot of times. when they are installed the kinect is getting identified by the os an still blinks green. a little spongy I know…

what does the Kinect Status output say?