Red line under quad menu

While working on a bigger patch, I sometimes encounter a red line under the gamma quad menu after changing something in the patch. I assume that somethin wasn’t compiled right. Sometimes, the red line is there after the orange one just for a second and something in the patch isn’t working as it should, e.g. reading and interpreting JSON. No red or purple nodes, just no output. But I can’t figure out why it’s not working and what the red line means.
Are there tools to debug? There is nothing in the console.

Best, avaos

When it’s present, I can hover it and it says Hot Swapping.

red_line_hot_swapping

hey avaos,

which version are you using? the red bar is no longer showing in version >= 5.0 and issues like you describe also sound like they could be fixed already in more recent releases. so can you test this against latest stable?

Hey Joreg, thanks for answering.

The Version is 2021.3.3. I didn’t patch it by myself since I’m still not so familiar with gamma enough, I just have to update some stuff now and having a bad time. It was running quite stable before I touched it. :D
I tried to load the patch with other versions already but I can’t even open. Tried it on another PC. It’s crashing while loading. I’m sure it’s because of some dependencies. Is there something I can check to debug startup crashes? I’d like to find out which of the dependencies or nodes it’s crashing on.
And, is Hot Swapping is something core vvvv gamma or used by some type of nodes? Maybe OpenCV? Thanks!

this is odd. so you’re saying you start vvvv gamma 5.0 and then, when opening the patch saved with 2021.3.3 it crashes? how exactly? ideally in case of problems loading it would open a Log window with an exception. is this not the case?

in that sense it is a core something and has nothing to do with a particular library.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.