"Range check error" when using DX9

alpha
fixed-for-50beta35-7

#1

Hi,

I’m new(ish) to VVVV and am having many issues getting DX9 modules to work.

Whenever I load an example involving DX9 modules, for example Graphics/DX9/Shader/Shading_Overview.v4p, I receive a popup stating:

There was an error during the execution of this program.
The application might become unstable and even useless.
It’s recommended that you save your work and close this application.

Range check error.

Indeed, I’m getting a similar message even doing something as simple as drawing a line. The only line example which does work is the “Joy Division” one, which appears to use an alternate (“legacy”) version of Line.

What might be going on here? My drivers are all up to date. I’m having this issue both in 32 and 64 bit. I’m using the latest alpha of VVVV (as I am also using VS 2017 on this computer and thus need the updated VVVV installer that recognizes 2017 and 2015 runtimes are compatible). The stack trace is below:

Thank you!


Exception class: ERangeError
Exception message: Range check error.
Exception address: 006E17B7

Main thread ID = 9040
Exception thread ID = 9040

Exception stack
Stack list, generated 5/18/2017 2:38:30 PM
[006E17B2]{vvvv.exe } ex9EffectWrapperNode.TMex9EffectWrapperNode.RenderCurrentDevice (Line 694, “ex9EffectWrapperNode.pas” + 26)
[004047BE]{vvvv.exe } System.ErrorAt (Line 4349, “System.pas” + 3)
[00404802]{vvvv.exe } System.Error (Line 4360, “System.pas” + 1)
[006E17B2]{vvvv.exe } ex9EffectWrapperNode.TMex9EffectWrapperNode.RenderCurrentDevice (Line 694, “ex9EffectWrapperNode.pas” + 26)
[004068A0]{vvvv.exe } System.TObject.GetInterface (Line 13236, “System.pas” + 8)
[004068E9]{vvvv.exe } System.TObject.GetInterface (Line 13243, “System.pas” + 15)
[006DF39B]{vvvv.exe } ex9AbstractRenderNodes.TMex9RenderStateNode.SetCurrentDevice (Line 202, “ex9AbstractRenderNodes.pas” + 2)
[006DF0DB]{vvvv.exe } ex9AbstractRenderNodes.TMex9RenderNode.Render (Line 137, “ex9AbstractRenderNodes.pas” + 5)
[00891890]{vvvv.exe } ex9GroupNodes.TMex9GroupNode.Render (Line 97, “ex9GroupNodes.pas” + 6)
[00887478]{vvvv.exe } ex9RendererNode.RenderViewport (Line 704, “ex9RendererNode.pas” + 90)
[008877F7]{vvvv.exe } ex9RendererNode.TMex9RendererNode.Render (Line 733, “ex9RendererNode.pas” + 20)
[00886EC9]{vvvv.exe } ex9RendererNode.TMex9RendererNode.Render (Line 597, “ex9RendererNode.pas” + 14)
[0074D803]{vvvv.exe } RendererNodes.TMRendererNode.RenderCB (Line 288, “RendererNodes.pas” + 2)
[00811555]{vvvv.exe } Events.TMEvent.Call (Line 403, “Events.pas” + 11)
[0080BAB4]{vvvv.exe } MainLoop.TMMainLoop.DoTimer (Line 227, “MainLoop.pas” + 46)
[005E4A75]{vvvv.exe } IdleTimer.TMIdleTimer.AppIdle (Line 152, “IdleTimer.pas” + 46)
[0052C195]{vvvv.exe } Vcl.Forms.TApplication.Idle (Line 10742, “Vcl.Forms.pas” + 7)
[0052B45F]{vvvv.exe } Vcl.Forms.TApplication.HandleMessage (Line 10194, “Vcl.Forms.pas” + 1)
[0052B791]{vvvv.exe } Vcl.Forms.TApplication.Run (Line 10332, “Vcl.Forms.pas” + 26)
[00A8DCED]{vvvv.exe } vvvv.vvvv (Line 160, “” + 7)


#2

can you tell us your graphiccard and operating system?


#3

did you try an alpha or beta version?


#4

Thank you for the quick responses!

My video card is a GeForce GT 720. My OS is Windows 10 Pro (64 bit). Both are up-to-date (drivers, etc.)

50alpha35.6 is the version of VVVV I am using (x64, with addons) because I needed the installer to recognize the 2017 libraries, which the beta installer does not.

I just tried running 50beta35.5 (directly running it, not trying to install) and the examples work in that!

So it looks like this issue is limited to the alpha.

I’m happy to attach the stack trace, etc, if the devvvvs are interested in addressing this further.

Are there any issues with me just overwriting the alpha files in my VVVV directory with the beta ones? That way I could keep on using the beta version without the need for the installer.


#5

hei mfan, thanks for the details so far.

never! modify any files in the vvvv directory except placing the \addonpack there and the other \packs. everything else should always be untouched to avoid confusion.

running setup.exe is not important as long as vvvv runs. you can easily have multiple versions of vvvv (alpha, beta) on your PC and use them one after the other without running the setups in between.


#6

wonderful. can you tell me which alpha this is?
press Alt-A for an about box. Tell me the build date. Thanks.

EDIT: tell me: did you install the addonpack?just post the screenshot of your about dialog


#7

Hi @gregsn.

Here’s the screenshot from the 32 bit build (I have the same version of the 64 bit installed too; both experience the same error):


#8

alirght. this should be fixed in newer alphas.can you confirm? sorry for the trouble!


#9

Just downloaded the newest alpha to test and can confirm: the issue is now fixed.

Thank you for the super quick resolution!


#10

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.