Random movement


in the last days I was trying to set up a random movement for an object. At first I used a random node, but the object just appeared and disapeared in different parts of the render (obviosly…), but I wanted it to be a smooth movement. therefre I added a damper-node and oscillator-node, to slow down the process. But with this setup the object concentrates in the middle of the render-window. I understand what the program is doing but how can I avoid this problem? Is there a way to let the random node create smooth output? Let’s say going from -0,5 to 0,9 to 0,2 without jumping around like a crazy?? (obviously I mapped the random-node output (0-1) to -1 - +1 to fit with the coordinates of the render)

Greetings Leo

I don’t know what you need it for, but in most cases it makes sense to enable the RANDOM just for 1 frame every X seconds. you can easily achieve this f.e. with a LFO and a CHANGE on its cycles pin, and connect this to the enabled pin of the random node.

this sounds good and it makes sense!

Thanks phl, I will give it a try when I’m back home on my pc (here in the uni I have just macs…)


it worked!

I tried to make a similar setup with more objects but than it doesn’t looks very random… any suggestions?

randomstuff.v4p (9.5 kB)

Hi Leo,

You can try this…
Tick “Is Integer” on the Random linked to Random Seed and increase Scale; no need the duplicate all your nodes, use spreads (see lfo’s periods) and Vector (2D Split) so you can save perfs…


randomstuff.v4p (8.2 kB)

thanks Alecz,

this looks much more “natural”. It looks something like a swarm behaviour, very interesting! I added two inputs for the lfo-period, so the behaviour is even more random.
I think when vvvv will have more output-funtions, better shading and stuff like that, it could become even a tool for creating special effects :-)

I guess vvvv can also be a good tool for generative design!
My next holidays will be in front of the pc!

thanks again