Forum

Random hang ups

it appears to me sometimes that while i am patching vvvv completely hangs up. i mean…i still see it running, but no mouseclicks or keypresses have any effect. everything is blocked and i only can quit vvvv via taskmanager.

this gets on me nerves!

hello joreg.

thanks for sharing your finding with us. we are really sorry for those inconveniences. but may we offer you a simple fix for most of those hanging situations. please just _rightclick on vvvvs button in the taskbar and say a little prayer. and voila. in many cases vvvv will pop into life again.

good lukc.

Dear Joreg,

also randomly I cannot save patches any more.
The parent patchs file disappears as if it was deleted from my hd and all I can do is quit vvvv and patch it once again…

mm. this is probably unrelated. though not less fukcy.

Dear Sven,

when you cannot save your patch,
is it that after saving that * behind the patchname doesn´t vanish?

if this is the case,
did you ever try to
1.) select all nodes (whole patch)
2.) copy (ctrl-c)
3.) paste (ctrl-v) into a textfile
4.) rename extension from .txt to v4p

worked for me but is long ago that i needed this.

did this ever work?
actually it would be a pretty amazing feature - copy from vvvv, paste to texteditor, mess up at will, copy paste back into vvvv etc.

@oschatz:
long ago:
this was a hint you gave me once when you were in wiesbaden with max.
yes, it worked.
was beta3 or 4…

Doesnt work anymore, just tried!

Dear Kalle,

it is exactly the problem you mentioned.
So I am not the only one still having it?
What could be it’s cause and is there a chance to get rid of it?
Maybe Joreg has an idea.

Or perhaps Joreg?

joreg?.. no text …

yes. the “cannot save” error is severe and shit. problem. nobody has yet found a way to reproduce it. if anybody finds a way he can describe that causes this problem i would love to hear it. i don’t know what it is caused by.

the copy patch to clipboard feature could be easily activated again. the other way round clipboard to patch sounds more problematic…

@sven: It is in fact very long ago that i had this bug. like joreg wrote: it seems not to be reproduceable.

it seems that the save problem , come from io boxes , or node like get patch and set patch.
Easy to see with setpatch , but difficult to reproduce with a buggy io boxe
Sometime when this problem appear , i try to delette one io boxe and save , an other and save …
sometime i found the good one… and thats really save