Work is underway on RCP, the “remote control protocol” which will see an integration in vvvv.

It is now in a good state to be tested. also available for VL now: https://www.nuget.org/packages/VL.IO.RCP

Here is a demo of using it in vvvv gamma:

update 24 02 21

update 20 10 20

  • renamed to VL.IO.RCP
  • fixes issue with not being able to bind to
  • added Enabled input to Rabbit node

update 16 10 20

update 05 12 19

update 18 11 19

update 14 12 18

update 28 08 18

  • changing min, max, default on an exposed number iobox is now immediately reflected on the exposed parameter

update 25 08 18

  • can now also expose IOBoxes that are connected upstream, ie for readonly display of their data

Hi joreg,
I really like the webclient and want to change some enums via VL.RCP, but I can’t figure out, how to set a “EnumParam” with multiple enums. My dropdown list is always empty.
How can I set multiple enums ?

@still not exactly sure i understand what you mean, but there’s been a fix regarding enums in latest b39.1 previews. so please try with that, maybe that solves your issue already. if not, please try to rephrase…

Thanks for the fast answer @joreg !
I also used ‘Rabbit’ in beta first. Unfortunately the webclient always created a checkbox instead of a button when I used a bang as parameter, so I used rabbit in gamma.
There the webclient created the desired button, but I didn’t figure out how to use ‘EnumParam’ there, or how to insert multiple strings, which I can select in the Webclient.

@still the input to specify the entries of an EnumParam was indeed missing. please update VL.RCP to find the new “Entries” input on the EnumParam node.

1 Like

Hello @joreg
Thanks for sharing RCP! I tried vl.io.rcp 0.3.0 in vvvv gamma 2020.3.0. The rabbit component worked fine, just the web app didn´t show the exposed parameters (screenshot attached). Any idea why it didn´t?

And also is there a way to update the exposed parameters from another vl sketch? That would be amazing!

Thank you and all the best,

does it help if you disable the “tabs in root option” on the client:


@joreg yes it does! I would have guessed I tried but seems I didn´t. Thx for you help!