Queue (Spreads) frame count bug?

Hi All

I am experiencing a behavior I cannot understand. I have made a patch where I am using Queue (Spreads) and I set framecount to certain value, in this case 1800 and I insert single slices of integers into it from time to time.

When I insert slices into the Queue then the spread size increases correspondingly, except for the last slice. I can fill it up to 1799 slices and continue adding more slices but the slice count never rise any further. I would suspect it to rise to 1800 before beginning to shift values out of the queue.

I tried to replicate this behavior by copying the relevant part of my patch to a new patch just containing this part, but when I did this the strange behavior disappeared. I have tried in beta 22 and 23 same result. I have a screenshot attached that show the infected nodes. the switch node before the Queue is for resetting the 1800 coming into the frame count of the Queue does not change.

A related question is, what is the frames output of the queue doing?

Perhaps related to this.


queue_count_mismatch.gif (4.8 kB)

Like in kalles case, Renderer (TTY) is quiet.

hi sune

are you absolutely sure that you didn’t feed NIL for one frame into the buffer?
in that case the queue would actually hold
1800 spreads with
1799 spreads with length 1
and 1 with length 0 (NIL)

a patch demonstrating the error would be vvery helpful ;)
please retry reducing the patch in small steps.

like most of the time you are right Sebastian. one off the last slices were empty… I just count the length of the spread going into the queue and check if it is larger than 0 before I insert the new value. Problem solved!

I am however still a bit curious about what the frames output is for.