Quad DX9 - Enabled-Pin not spreadable?

I tried to disable quads, that are spreaded thru a list of points with the enabled-pin. it did it wrong :D on the server/client-setup it seemed to work ok with 2 quads, then with/after 3rd enabled-quad (in spread) it “freezed” the enable-pin, till all quads were erased… On one Machine just the first value of the spread is used, it seems…

Heres a small patch, it seems, that the enabled-pin on quad(dX9) works on this quad - regardless of the amount of spread-slices…

regards chmee

Quad_EnabledPin.v4p (4.8 kB)

West, thank you. I’ll put your patch into this thread. And you`re right, i thought about performance issues as i worked with the enabled-pin (as i thought, spreaded quads will be not instances, but a kind of copy with various arguments -e.g. enabled-pin :D

regards chmee

Quad_EnabledPin2.v4p (11.2 kB)

Sorry about that, my Popup killer went crazy With that link.

You can always remove slice of the transforms for the ones you don’t need.

If you open this patch, and open the Debug mode, it might look this last way is the fastest way.

Quad_EnabledPin3.v4p (20.4 kB)

west, thanks for it. i’ll try today if its an usable/efficient way in my patch.

regards chmee