i am testing the remoter for a group of clients and i cannot use the pstools part at all (start, restart, kill, wakeonlan, reboot, shutdown)
none will bring any reaction on the clients, nor on the server.
i have copied the \pstools\ folder in the proper locations…
any hints about this ?

helo gg,

as stated on the RemoterSA page there is this thread about getting pstools to work. have you checked that?

I had problems for ages and then read the line ‘On your target machine check if it is not running Windows XP Home’.

amazing software when u do finally get it working. I get a real buzz from using RemoterSA, nurd-tastic I know.

I’ve never managed to get it to work either, not running home, tried all the things that should do it, I think!
It certainly sounds very useful!

also had some troubles, but at the end it was quite simple:

  • put the pstools somewhere on your hd of the server (clients don’t need them)
  • tell remoter where they are
  • disable simple filesharing
  • give all clients the same admin user and admin password
  • tell remoter the user/password

as far as i remember that was all you have to do, but i didnt try it with win7.

I would add also :

Go to Local Security Policy.

Inside Local Policy go to Security Option.

Then modify the key named : NewtWork Access : Sharing and security model for local account. with Classic - Local users …


@joreg: now i have and it solved my problem. tx !

the one setting that was missing for me was
my computer > tools > folder options > view > uncheck ‘use simple file sharing’

the other options were pretty much default with my winxp-sp3

If anybody could post instructions to run RemoterSA on Windows 7, I would appreciate that very much.
I am sitting here and i cannot use PsTools at all. I assume its the security settings. the option “use simple file sharing” is not available on windows 7 (vnc works though, as well as accessing the client´s shared folders through the explorer).
thanks to all

Some time ago i wrote down how to instal PS/Shoutdown. Probably it helps anybody. But it was on a XP Maschine.

Local machine: the machine where you logged in and where you type in your PSTools command.

Target machine: the machine where you want the PSTools command to execute something remotely.

\target: same as above, substitute “target” by the real machine name or by the appropriate IP address.


  1. Set up your maschines like it is descripte in How to Setup a new Machine

  2. The same user Name (e.g admin) and password (e.g. meso) on every maschine (Remote and Locale). Empty passwords are not allowed!

  • Change Autologon: Start→ run → “control userpasswords2"
  • Press Strg + Alt + Enttf and select “change password”
  • Set an password and commit
  • The User must have administrator privileges
  • Restart to check if the Autologon still works and the settings are recognized by Windows
  • Remote Maschine
  1. Check if services “Workstation” and “Server” are running

  2. Go to Run (Windows Button + R)

  3. type “services.msc”

  4. Go to the Services Workstation and Server and set thus as aktive.

  5. Turn off simple file sharing andturn o n classical file sharing.

  • Click Start | My Computer | Tools | Folder Options | View.
  • Scroll to the bottom of the list of advanced settings and un-check Use Simple File Sharing (Recommended).
  • Click OK
  1. Turn of network users identify as guests and turn on network users identify as themselves.
  • Go to Control Panel → Administrative Tools → Local Security Policy → Local Policies → Security Options
  • Look for the line “Network Access:Sharing and security model for local accounts”.
  • Right Click and Select Properties.
  • Change Pulldown Menu to “Classic - local users authenticate as themselves”.
  1. Check if the the Admin$ share is available.
  • Go to Control Panel → Administrative Tools ->y Computer Management
  • Expand the Shared folder
  • When the Admin$ is there everthingis fine and got to the next Point else go one
  • Click with the right mouse button on Shares, and click New File Shares.
  • Enter in the field Folders To Be Shared the path %SYSTEMROOT%.
  • Enter: Admin$, and click Next.
  • Check the box Administrators have full control, other users have no access to restrict access to the release to administrators.
  • Click Finish and No, to go back to the Computer Management console
  1. If thre is any firewall on the Target maschine Port 445 has to be open incoming traffic from your local machine

  2. When all these changes are made got to the local maschine.

Local Maschine

  1. Download PSTools to your Local maschine:

  1. Extract to an Directory of your choice e.g “c:/PSTools/”

  2. Test the Remote Connection and the Target Maschine Settings.

As soon as your target machine meets all of the above listed requirements, from your local machine try to execute these commands to your target machine

  • Open the command prompt
  • net use \target\Admin$ /user:Administrator
  • dir \target\Admin$
  • net use \target\Admin$ /delete
  • If these 3 commands work, then it should be possible to run a PSTools
  1. Shutdown the the Traget Maschine with a Command e.g.

"C:/PSTools/ psshutdown -u admin -p meso -f "

Know on the Target Computer should appear a PopUp with Count down from 20 to 0 and the Shoutdown Windows gracefully.

More Commands for PSTools/Shoutdown can be found here:

hello again.
hmpf… im working on another multiclient setup, and i cannot make the pstools working. of course, neither the remoterSa works.

im using as a server my laptop with windows home.
the clients have xp professional, and i actually tried everything described here in the thread. but… the username contains two words. e.g. “Hello World”. Could that be a problem? i haven´t tried to change this yet…


You can shutdown pc with node Shutdown(Windows). It’s works more stable, than PsTools.

Hi alg. I need to use the remoterSa…

windows home is the problem I’d guess. probably need professional on laptop too

I can get pstools to work fine, but can’t get remoter to work with them… shame it looks really useful! Especially the watching threads to see if they’ve hung…

sou, ja there was a bugger that would prevent remoter to work on win Vista/7. fixed that, see contribution RemoterSA beta6. also note that for win Vista/7 an extra registry key needs to be set. i added info on that here: RemoterSA

i cannot tell for sure, maybe it also fixes problems catweasel had on win XP. didn’t check beta6 on XP at all though so would be glad to hear back from you if it works.

@aivenhoe: don’t know about the two worded login name. best you create a completely new account. i remember having had troubles with a renamed account that wouldn’t work.

so does remoter & pstools work on windows 7 home or does it need pro?

i can’t say. i’ve tested it between two win7pro PCs.
note that on Please READ Before POSTING they point out that only the remote/target PCs must not run win XP Home. seems the local PC can run win XP Home. so this should not be aivenhoes problem he mentioned above.

Hey there,

has anyone tried using RemoterSA with Windows 8 yet? I can get it to open and give me errors like wrong username/path etc. After I configure everything correctly, clicking on Start doesn’t seem to do anything or give any errors though. I tried running PsExec from command line and it works fine (opens the app on remote pc). Let me know if you’ve tried this on Win8 and if it worked for you.


In Windows 8 you need to enable Admin Share

Hey alg, thanks for the reply. I tried modifying the registry to enable Admin share but no luck. Turns out I just had to run RemoterSA in admin mode (doh!) by right clicking and selecting “Run as admin”. I guess you still need to enable file and printer sharing but no need to add a new key to registry. Just in case someone else runs into the same issue.