Problems with VVVV and retina display ~ scaling and fullscreen mess

…in fact it’s not a retina display but a QHD+ display on a Dell XPS15. Resolution 3200x1800.
The system is set to scaling to 192%, OS is Windows 8.1

Now, if I open a V4 patch, everything looks fine at first. The scaling glitches which have been reported on a MBP retina display don’t seem to occur. I see all the node connections and the node-names are readable as well.

As soon as I switch any renderer to fullscreen, the mess begins: the actual content of the renderer is not displayed but some parts of the desktop, the patch it self as well as the renderer in some scaled madness.

As soon as I switch back from fullscreen mode, the scaling for V4 is disabled and all V4 windows appear scaled to 100% (which is very small at 3200x1800). In addition to this, the properties of VVVV.exe automatically enables the setting “deactivate scaling on high dpi settings”… which results in the 100% scaling of VVVV. This setting comes back every time a renderer is set to fullscreen.

Interestingly setting a renderer to fullscreen ALSO doesn’t work on this machine when the display settings are set to normal HD and the scaling is set to 100%.

Any ideas how to solve this?

maybe nvidia optimus problems? search the forums…

it might be a mix of two or three problems:

a) NVIDIA Optimus
I think this might be the case because, when I tell the system to open vvvv.exe with the descreet 750M grxcard, fullscreen mode does not work. When I choose the onboard HD-graphics the fullscreen mode works.

user screamer apparently has the same [issues))](

EDIT: actually not only the fullscreen doesn’t work as soon as the GT 750M is activated, but the renderer stays plain black, no matter what’s connected to it. This only occurs when the GT750M is on (according to the Optimus Test tool).

b) scaling problem due to high-res screen
When I use the system scaling function to make the screen usable at 3200x1800 (e.g… set to 150%) the setting for V4 gets messed up after setting a renderer to fullscreen and back. V4 is still open then, but the scaling is resetted to 100% for V4, the box “deactivate scaling on high dpi settings” is ticked and the GUI is scrambled.

c) fullscreen issues due to this registry key ‘MAXIMIZEDWINDOWEDMODE’

I didn’t manage to solve the problem by removing the key or changing it o ‘0’. After a system restore it is gone for now, but the problems didn’t resolve.