Problems detecting a simple arduino input button

Hello everyone,
i was trying to reproduce this simple button tutorial found in the arduino website
inside the sample arduino help patch.

I simply set the pin2 (tried with other pins too) to INPUT (but tried all the other possible pinModes too) and pushed the button, but nothing happens. Inside the help patch i cannot see any input changing, while if i try the sample arduino code found on that webpage it works, so the schematics and wirings are ok.
I have tried with other sensors too and vvvv is reading the correct values.
This is my setup:

  • arduino uno with 2.3 StandardFirmata
  • vvvv 45b31 or vvvv 45b31.2
  • win8 x64

What am i missing?
Hope you can help, thank you very much!

Hello crash,

just to be sure, you’ve chosen the right port for the ComPort pin and turned on the Enabled pin of the Arduino (Devices StandardFirmata 2.x), right?

What do you mean by:

I have tried with other sensors too and vvvv is reading the correct values.



Hi robotanton and thanks for your answer.
The arduino is being correctly detected and i have tried some inputs like potentiometer, light and touch sensor, and some outputs like leds and servos with the tinkerkit shield and they all work using the sample patch and the settings stated in the previous post.

I have done another simple test by changing the wirings of the example shown in the tutorial
and i was triggering the led just by directly connecting the +5V pin to the DIGITAL PIN2 and the output was the same as before: it works with the arduino code, but it cannot achieve the same with the arduino help patch.
Hope this can give you some more hints, thanks again for your support!

Hello crash,

please try to switch off the Report Analog Pins pin and then bang the Reset pin of the Arduino node in its helppatch. Can you see now working pin2?