Problem with writing frames and Windowed vs. Fullscreen

Hi all,

I have a patch where upon a button press I want to write a frame of a webcam stream to a folder (and subsequently, directly read all those frames, spread them on a bunch of quads whereas the last picture written gets a special treatment).
This works so far - unless the patch runs Fullscreen. Then, the particular very first frame taken/written in fullscreen mode is always empty, which in turn makes the last picture read the second-to-last. Any ideas how to fix this?

thx, purf

edit for another, clearer patch of what’s (not) happening

callmenames.v4p (43.2 kB)
inotherwords.v4p (11.0 kB)

Aaah, really, noone? Shameless bump, then - this thing is driving me nuts. So, just in the very likely case the above didn’t make any sense, here’s a picture:

On a bang I am writing the current frame of a video stream, then stuff happens, then there is an output renderer. Only that, when the output is fullscreen, I am unable to write the current frame - instead vvvv does some time travel thing and insists on writing the frame from the Bang before… the first picture I take is black, the second picture becomes the first one, the third the second and so on. I tried to use the other ‘Writer’, but to no avail…

Pleaseplease, what’s going on?

are you still using Writer (EX9.Texture NRT)? if so, try using Writer (EX9.Texture) instead

I don’t know what I was seeing the one time we were on Skype, because this weird behaviour persists regardless of which Writer I use…

I am on skype now if you want to ping pong

gotta fetch the kid in about 10 minutes… But here’s something: What is a Renderer’s ‘Device’ setting in the Inspektor actually doing? Because, set to 0 instead of -1 on the output lets me indeed save the right frame. While introducing a new problem of course… However, later today I will hook it up to a projector - maybe this again changes something.

So… I tried running the patch in its actual environment - as in on a second monitor aka soon-to-be projector… and the whole issue resolved itself.

Nothing to see here, move along =D