Problem with texture queue/getslice/sending

Hi, I’ve run into a little problem with a combination of the texture queue node, the getslice node and the “S (Node)” node. I’ve included a patch which I think demos the problem better than I can explain here, but it seems as though when I send a texture which has been selected by the getslice node through a “S (Node)” node it ignores which slice I had selected and only sends the slice at index 0.

I hope this makes sense when you look at the patch…


send problem.v4p (6.5 kB)

wow, nice one…

hm if you set the getscliceIndex = the framecount it works fine …

Thanks tonfilm, I ran into the big when trying to incorporate an effect like the granular video girlpower patch into my performance patch. In my patch I tend to use sends a lot to allow for a really modular architecture for mixing between patches (p.s. a way to group send enumerations by type would be handy, as I send transforms, 3d layers, and textures around with S(node), and all too often I get lost in all the options!).

When I brought the granular video stuff into my patch I noticed the effect only worked when directly patched and not when sent…which is a bit irritating, but not too big of a deal.

Milo: Yeah getscliceIndex = framecount works because that’s the same as setting the getsliceIndex to 0 (because the slice indices start from 0 and the framecount starts from 1), so as long as you only want the first slice you’re set ;)