Phidget rotary encoder not showing up

it’s been a while… so I guess I’m missing something simple when connecting a phidget rotary encoder via the 4x high speed sensory board to IO (Devices Phidget).
phidget control panel shows the input, VVVV does not. correct serial number entered, apart from that nothing in the patch. what did I forget?
thanks for helping me out!

ps: this project proudly bought a licence and it has been shipped to australia within seconds. top ebayer!!!

did you install the phidget drivers?

Yep, I did that. That’s why I can see the input in the Phidget control panel, and there it works fine.

hi phl,

if you are talking about this board
It is from the type encoder not IO. So you have to use this Encoder (Devices Phidget).
hope this solve your problem.


thanks nils!
I’m pretty sure I tried that (tried them all :)) - but probably without restarting VVVV with already entered serial. I’ll give it a go tomorrow and report, not at the setup right now.

thanks, works like a charm!
to summarize it, I missed two things:

  • used IO (Devices Phidget) instead of Encoder (Devices Phidget). encoder is the right choice.
  • in the current version (45beta28.1) the patch needs to be started with the serial already entered. practically this requires a patch restart when trying it out.

fixed the reconnecting bug for > beta28.1