Forum

Patch wont open

i was paying arround with a help file and had an interesting result, so i saved it in another folder, When it asked me if i wanted to reload it, i said yes, the patch went blank and now it wont open again.

i cant open it at all , havnt tried Xml yet, but its not the first time it happens.

anyone knows whats wrong with this?

Hello,

havnt tried Xml yet, but its not the first time it happens.

Did you try to drag and drop the .xml file into v4 ?

so you have a broken .v4p that you can’t open?

you could try to open it with XMLmarker and see if this already points to some xml error

or attach the broken patch here

open an empty/new patch and create a Renderer (TTY) and then open your patch.
TTY should point you to an error and the line in the .v4p file where it occurs. Use XML-Marker as Kalle already suggested and try to fix it.

After installing 25.1 one of my subpatches from a 24.1 project won’t open in the new version.
I followed the advice above and used the tty renderer, but i don’t understand what its telling me and how i can fix it! It’s a really simple subpatch that refuses to open, and multiple versions of it won’t open either.

This is what the tty renderer displayed when i try to open the faulty patch:

00:04:06 * : patch G:\VVVV\vdocuments\general multi fft patch\generalmultifft_ver.0.6\subpatches\subpatches\morphshapes_rotatewhole.v4p has been converted from versions/vvvv45beta24.1.dtd to 45beta25.1.
00:04:06 * : didn’t create node; [G:\VVVV\vvvv_45beta25.1\root.v4p, without name (ID: 50)](G:\VVVV\vvvv_45beta25.1\root.v4p, without name (ID: 50)): Access violation at address 006B9E99 in module ‘vvvv.exe’. Read of address 00000000
00:04:06 * : couldn’t find/create node without name (ID: 50) in patch G:\VVVV\vvvv_45beta25.1\root.v4p. deleting action.

Can anyone tell me how to fix that?

thanks very much

hm…it is not obvious from there…could you post the bugging patch?

Here it is, forgive the mess!
It still opens fine in 24.1 just nothing in 25.1

thanks

morphshapes_rotatewhole.v4p (17.4 kB)

delete line 50 to 57, there are empty tags
opens up in 25.1 then

Do you mean in the xml marker mentioned earlier in the thread? or is there a way to do that through V4?

thanks

you can just open up the .v4p in any editor and delete the lines.

why would you want to do it inside v4? you would have to create a new patch, read the broken .v4p via reader, do the string operations, save the file again…

Actually it would be quite nice if v4 could deal with these errors on its own.

Brilliant, thanks woie - it took me a while to realise you meant any text editor, but yeah that was dead easy!

thanks for reporting, fixed for upcoming release