Particles (Spreads) plugin

only an anouncemount:
i encountered really strange behaviour of vvvv when using the Particles (Spreads) plugin by tonfilm.

as soon as i have a steady internet connection i will provide an exemplary reproducing that behaviour.

as promised:

*open the attached Paint (EX9.Layer) with buggy particles.v4p with a texteditor/xmlmarker to see that it contains two InvBrush.fx
*open the patch with vvvv: the two InvBrush don’t appear in the patch.

00:01:39 * : didn’t create node; C:\Users\chef\Desktop\PYC 20100401\Subpatches\DrawMask (EX9.Texture)\Paint (EX9.Layer) with buggy particles.v4p, C:\Users\chef\Desktop\PYC 20100401\Subpatches\DrawMask (EX9.Texture)\InvBrush.fx (ID: 1): Variant or safe array is locked

closing vvvv results in

instead opening the Paint (EX9.Layer) with buggy particles and Invbrush topleft.v4p instead DOES have the two shaders, but in the topleft corner and it is not possible to move them.

i only tried to add an IObox (string) with a comment here…

Paint (EX9.Layer) with buggy (27.9 kB)

hello kalle,

for me the two patches are quite the same, both have the InvBrush shader on the top left. i doubt it has something to do with the Particles. its rather having the same shader two times in the patch. if you look in the .v4p the InvBrush nodes have no content… you can add a BOUNDS tag to them so you can move them around again, but then you see, that on of them has nil in the techniques pin… i would delete one or both, save the patch and rebuild it again.

hey tebjan,

the really strange thing was that this patch worked wonderful the last 4 weeks and the problems occured almost immediately when i added the particles for an experiment…

ja, there were 2 instances of the shader in the patch. but it is just a slightly modified Constant.fx .

maybe i broke the particles while using “wrong” parameters. but i am very sure that the particles is the REASON that the patch broke.

about “wrong” parameters: somebody here also occassionally experienced “sudden death” when changing values by “rightbutton-dragging” on a pin of a plugin?