Pade / 3D Object doesn't look right

we have a problem using the pade node. After calibrating teh 3d model with the pade it looks ok in the wireframe mode. But after using a texture on the pade transformed model the pade´s output shows the cube like you can see in the attached file. We attached anothe renderstate node (zwrite) to the pade and the output is changing but it never look ok.
Because of the pade node outpts a layer and not a mesh the depth buffer in the renderer doesn´t have a effect on this. we think this happens in the pade node. Does anyone know about this problem ? Thank you !
Greetings Stephan

Post the patch of you can, however issues with pade I seem to remember have come from the model being too big I think, so as a quick test rescale your model so it’s vertices lie between -1and 1
Kalle I think has a module for doing this kind of thing, I’m on a train on my phone so can’t go look for you…
If you know how to vertex buffer mesh join etc you can patch one yourself…
Often if the model has co e from a 3d program they can big scaled very big when importing into v4
If that doesn’t work wait for elliot to help you!

ok, this post wat clearly in the wrong thread… seems I have some problems posting atm.

I am working together with stephan. Our patch is attached and a pic of the problem.

I don’t think it is the “bigger than 1” Problem because we tried it with smaller objects but the problem didn’t disappear.

It looks like this depthbuffer thing that sometimes appears with GouraudDirectional and Textures and which can be solved by changing the Depthbuffer Format to “D24X8”.

But if i change this at the renderer of the pade shader, nothing happens.

Do you have any idea? Thank You!

Greetings from Cologne,

Pade (99.6 kB)

sorry this is a known issue (with available fix!)

The pade shader wasn’t giving out a Z value, so therefore the depth buffer would have no data to work with

Please replace the

float coefficient(int iDimension, int iCoefficient)

float4 PadePosP(float4 PosW)

functions in your pade.fx file with:

(replace the old 2 functions with the 2 new functions)

or perhaps just download the whole thing at: (needs testing)

Tested it, works fine!

Thank you very much, Elliot!