OSC between Max & Vvvv going weird

Hey everyone.

I’ve another issue with OSC between Vvvv and Max/Msp.

I am sending 3 0-1 from Max to Vvvv and there should only ever be one 1:

001, 010, 100 etc

I don’t quite know how to explain the issue I’m having so I’ve made a quick video:

If anyone can take a look and let me know why the numbers in Vvvv are not staying as they are in Max, that would be really helpful.

Thank you.

please upload the patch as well.

maybe you are sampling the 0 from the default value of the AvoidNil when no numbers arrive on a specific OSC address or a number from another address when not all numbers are sent. see the OSC_Advanced.v4p how to correctly GetSlice the values corresponding to an adress using the Bin Size out of the OSCDecoder.

I’ve uploaded the patches, both the maxpat and v4p too.

I’ve had a look at the OSC_Advanced (Uploaded in this thread: OSCEncoder how to pack values to send? But that’s not making much difference, unless I am doing something wrong.
I’ve uploaded the changed one after looking at OSC_Advanced to see if I’m doing anything wrong.

It’s strange as I’ve other OSC connections set up between the two programs and they’re working pretty well.
This is sending on a different port so that there’s not a huge load going over one port.

Thanks for your help guys. This is for my final project at uni and OSC between the two programs is pretty fundamental to what I’m doing.

OSCissue.rar (4.4 kB)
OSCissue2.v4p (9.9 kB)

as tonfilm mentioned you sampling the 0 from avoidnil, when nothing comes in anymore. to solve this place an S+H (Raw) between the UDP (Network Server) and the OSCDecoder (Network). with the Queue Count output going into the Set of the S+H. that should do.

Thank you for your replies.

I’ve made the change and done the above exactly (I think), however I am still getting the same results. I’ve uploaded the amended patch.

I really don’t understand what’s going on with this :(

OSCissue.v4p (9.2 kB)

not sure what you mean. attached seems to work for me.

OSCissue2.v4p (12.1 kB)

It’s still not working for me.

The numbers are just not correlating at all, for example:

Max —> Vvvv
001 —> 111
010 —> 000
100 —> 011
010 —> 100
001 —> 101

The numbers showing in Vvvv are in no way the same as those coming from Max about 90% of the time.

I’ve done some testing with Pure Data as well. OSC from Max to Pure Data is working fine. Everything correlates properly and works just fine.
I’ve then tried sending OSC information from Pure Data to Vvvv and exactly the same thing happens as when I send it from the Max patch to Vvvv.

PD. —> Vvvv
001 —> 111
010 —> 011
100 —> 010
010 —> 000
010 —> 001

I’ve attached some screenshots to show what I mean.
The numbers coming from Max/Msp are being shown in Pure Data correctly, though when they arrive in Vvvv they become jumbled.

you didn’t mention what you see with the sender i uploaded. changing numbers there leads to the expected result for me. also, can you upload the pod sender?

I’ve uploaded the Max, PD & V4 files in a rar.

Do you mean the numbers going in to ‘AsString’?
I have changed them ones but still the same. Am I doing something wrong here?

Examples.rar (5.2 kB)

ok, got it now. you’re sending the messages individually (as opposed to a bundle) thats why you’ll still need the S+H thats now unconnected in the screenshots. just connect its output to the unzips input and it should work as expected.

Thank you so much for all your help. I finally have it working.

It turns out that the issue I was having on my end came from Max. I don’t know why the values were being sent correctly to PD and incorrectly to Vvvv still, but I’ve changed the system in Max and everything is working just fine.

Very strange, but thank you still for all your help with this :)