Forum

OpenNI for alpha27.1

is it just me or the skeleton xy data doesn’t match the depth image? even when i go close the skeleton stays small, if i go far it matches. check attached patch

kinectcheck.v4p (6.8 kB)

@all:
the openni-kinect nodes are now shipping with the beta, so there is no need to use the alpha-forum anymore. don’t be afraid to start new threads.

@sapo:
the skeleton XYZ data is in real-world coordinates, therefore you cannot simply take XY, draw it flat in the renderer and expect it to fit onto the grayscale image.

use Perspective (Transform Kinect) to apply the kinects depth perspective to the skeletons XYZ output using multiply (3d vector) to get them into projective/perspective space where they fit with the gray image. see?

or check the Skeleton (Kinect OpenNI) helppatch.

thanks Joreg, yet i don’t understand very well what you said about perspective, but works :D
in the previous plugins they were simply matching and i got used to that.
I’ll just use the Skeleton (Kinect OpenNI) helppatch as base to patch.

hm…but you are aware of the different spaces, right? coordinates as returned by the kinect nodes are in world-space, as this is more comfortable when you want to use and combine them with other objects in 3d-space.

video-images (as well as the kinects rgb/depth-images) are in projection-space, which is only 2d. so if you want to overlay the skeleton data with the video-image you first have to bring the skeleton data in projection-space as well.

@Joreg: i heard them many times and read about them once, but now i had a re-read, if i understud right, since projection space is 2d, in the previous kinect plugins those skeleton cordinates were in projection space plus the Z?
About the admin problem of the other thread, also dl-110 has this problem if you scroll up here, would be nice to know from him if starting as admin fixed it for him too.

i cannot comment on the previous plugins implementation, but i am quite confident the way it is now is the most intuitive one.

installed all openni drivers exactly as described here: https://discourse.vvvv.org/
when starting a patch with kinect nodes i get the error you see on the image attached. also tried to install microsofts KinectSDK-v1.6 but this is only for win7. i am on winxp, beta28.1
there are some messages saying something about uninstalling the drivers then it will work? hm…

again, do i have to install all of them (dev or redist?)?:

OpenNI Binaries (32bit)
AND / OR?
OpenNI Compliant Middleware Binaries (32bit)
AND / OR?
Asus Xtion: OpenNI Compliant Hardware Binaries (32bit): from the same link above
AND / OR?
Kinect: SensorKinect binaries (32bit)

thanks,
confusius a

for me kinect works finally (on winxp, v4beta28.1) with the following drivers:

openni-win32-1.5.2.23-redist
nite-win32-1.5.2.21-redist
SensorKinect091-Bin-Win32-v5.1.0.25
(with “SensorKinect093-Bin-Win32-v5.1.2.1” it never worked. the kinect node could not detect/connect to the camera)

best
armin

and those are exactly the ones stated on the kinect page, right?