Open ni and ms sdk drivers installed on same machine?

Is it possible to do this and choose which one is active?

works with mssdk v1.5 and openni -

go to


There is an install.bat file. This didn’t work for me (in admin mode or not) so if you’re the same -

copy kinect-mssdk-openni-bridge-V10Release.dll from the bin folder you downloaded, into C:\Program Files (x86)\OpenNI\Bin (if your openni install is there)

open a command prompt (start button, type cmd) type cd C:\Program Files (x86)\OpenNI\Bin (or the location of your openni install) then press enter

type niReg.exe “kinect-mssdk-openni-bridge-V10Release.dll” and press enter

You should now be able to use either openni drivers, or mssdk drivers in vvvv. you can even swap between the two without restarting vvvv!

cool nice info

Cool trick, thanks! ;)


need openni and nite already installed?
and what about the sensor driver? I suppose I don’t have to install it…

thanks in advance for response


ok i tried… it simply works (without installing the sensor driver obviously).
Now I would know if it’s possible to use the user texture from openni and the tracking data from mssdk… just dreaming… in theory not.

But if someone knows more about…


Hey, can anyone confirm if the openni rgb is working with this setup? I only tested depth at the time. Seems there is an issue…

@robe I don’t think you can use both plugins at once in vvvv, though I think the whole point of the bridge is that calls can be made to both drivers, so it should be possible in theory

I try it, but it stated that “Failed: Failed to write to the file!”

I cannot find the version of Openni

Please help !!

I have the Openni and Avins kinect driver. Will up it somewhere and put the link here .

About the kinect-mssdk-openni-bridge i am unable to use rgb texture with the Openni drivers as well , also a lot of programs that need the Openni driver fail when i have both drivers installed .

Edit: here is the link :


Which is Avins kinect driver?

I’m using the bridge and am having lots of issues…

Ah, got it:

Seems to have possibly improved the skeleton tracking.

Still not RGB though :(

@kadinHilda had same error (“Failed: Failed to write to the file!”). Fixed this, both drivers continue to have problems.

Windows 8.
Disabled User Account Control.
Error continues.
niReg.exe compatibilty properties: “Run this program in compatibility mode for: Windows XP (Service Pack3).”
No more “Failed: Failed to write to the file!”.

This nodes are not working:
OpenNi: RGB
Microsoft: Player, Face, World, RGBDepth, SmoothSettings, Depth.

I have tried to install the bridge llike in the description above. But it doesn’t work.
Is there another way to make them both run on vvvv?

This is how I got them both working:

Either way round should be fine, it not - try the other way :)