One renderer over two screens

i have two screens that are set up as expanded desktop.
Now i would like to have my patch be in fullscreen over both screens. If i flag fullscreen on the renderer the patch goes fullscreen only on one screen.

How can i set it up to go fullscreen over both screens?


Hey pete,

You could try the Window (Windows) node.

It takes a Window Handle as input and allows to manipulate its size and position programmatically.

It also has a comprehensive help patch!

The cleanest way would be to have your graphics card handle this with i.e. nvidia surround and have those displays be configured as just one for your OS.
Expanded desktops are a different thing, and there may be other problems you run into (also depending whether you use dx9 oder dx11).

I am using the ex9 renderer and sadly the intel graphics driver rearranges the screens everytime i activate the “combine desktops” option. so i need a workaround. i looked into the Window node help patch but did not really get it.

i’m afraid i think you have to sort this on a windows OS or graphics driver level. vvvv is asking the OS for available desktops to go fullscreen on. so the OS needs to report both screens as one desktop in order for vvvv to be able to go fullscreen over both.

ok. the “combined desktop” works in landscape mode. as workaround i would like to rotate the renderer by 90°. is this possible? The nodes i am using are FileStream>Videotexture>FullScreenQuad>Group>Renderer(EX9)

You can rotate the desktop in two ways.

  1. Set the windows desktop to portrait mode from the windows graphics control panel.
  2. Use a rotate on the projection input of the renderer. Set z rotation to 0.25 or - 0.25 depending on the which way you want to rotate the image.

Thank you for your help but it is not working. What am i doing wrong?

Instead of a FullscreenQuad use a normal Quad + UniformScale(2) - in this case also disable the Auto Aspect Ratio of the Renderer using the Inspektor. Or don’t rotate the view but the FullscreenQuad itself.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.