Forum

nVidia Optimus and vvvv?

hi all

looking at a few laptops with nVidia GT 650M 2GB to run vvvv

this is an optimus card - just curious if everyone using switchable graphics is getting the flicker issue with multiple renderers open?
does the fullscreen output flicker too?

can anyone confirm this is an issue, as this looks like a great card

hope vvvv and optimus can play nice together, as it looks standard on all new portables now

Interesting thread about it

https://discourse.vvvv.org/t/6942

yes, i read that!

i use contour a lot, it needs it’s renderer window open

last 650m drivers were GeForce 306.97, released 16 days ago

anyone with a 6xx (or other optimus) updated to 306.97?

hi,
i have the 650m in my asus n56vz. leaving windows aero turned on avoids the renderer issues for me. no problems at all. still on the 296.67 drivers.

Only with aero turned on i have no problems with “multi-render-flicker”

My system is:

dell xps 15z
win7 home premium 64bit
Geforce GT 525m

Also wanted to get the new ASUS UX51 which has got the 650M.
Thanks for this thread. Now I’m not quite sure anymore …
Any news on that topic?

In that other thread io also said that even some games are having issues running on Optimus Cards, not only vvvv.

hmm seems aero solved this flickering 4 me cool ;]

okey super, for me too.
first time aero does not cause problems but solves them…

I can confirm the above mentioned issues. VVVV and Optimus without Aero don’t seem to be compatible. Turning off Optimus or turning on Aero solve the problem on my notebook (3rd gen. i7 with Geforce GT 640m).

hi guys, just a question: what about optimus on windows 8? because i cannot use the nvidia card with vvvv with my new laptop :\

You will need to add VVVV inside your Nvidia Control Panel, so it only runs in HighPerformence Mode using the Nvidia card.

The downside to this is that it might suck your battery dry.

Enable the “Display GPU activity Icon” to check if VVVV is using your Nvidia Card.

There are several settings that might have a huge impact on performance, depending on your rendering/output situation.

MultiDisplay/Mixed GPU acceleration for example, depends on what output you are using, but the setting will make a huge difference in some cases.

Ive had Problem whens changing some Antialiasing settings in the Nvidia Panel instead of VVVV. But you might need to check the settings yourself to optimize them. Changes will only take effect on VVVV after restarting VVVV, so its kind of painfull but its worth the time.

A suggestion:

Since this is an issue with various problems and solutions it might be a good Idea to document the ideal settings for different scenarios, based on user experiences. Its hard to avoid Nvidia these days, so a lot of us could benefit from eachothers experiences, settings screenshots etc.

Example:

Setup: 2 Renderers, each Fullscreen

Setting: Driver Settings, Registry Setting, DX Settings, VVVV Settings

Maybe we can add an entry somewhere in the vvvviki.

This would also be great for other common hardware.
Ive had problems with a Matrox TH2G that I could only solve by asking on IRC. Thx btw.

A list of these common issues with widespread ( spread hihi ) hardware would be great. In the troubleshooting section for example.

Hey guys,

Sorry, for bringing this back up again. Do we have an actual solution for the Optimus drama yet?

I just received a new DELL XPS 15 laptop which basically is unusable with V4, very likely due to Optimus Technology. I’ve been googling and hacking the Windows registry for several days now, but V4 just doesn’t do what it’s supposed to do.

I think I will have to send this laptop back and shed some tears about it, because it is really a nice and sleek machine. It’s a shame, because there is no real alternative! Do we need to stick to 5 year old technology with V4?

What’s going on?

1.) Rendering on the discreet graphics card does not work.
As soon as I tell the system to use the Nvidia GT750M graphic card for running V4, nothing is visible in the renderer. It just stays black. Interestingly, setting the renderer to fullscreen brings the content back, back to windowed mode > back to black. (reminds me of a good Amy Winehouse song? “Back to black”?)

2.) Multiscreen rendering does not work. As soon as I connect more than one screens to the machine and put renderers there, everything just starts messing up badly. flickering and weid display glitches on all screens. Settings in the NVIDIA Controlcenter “Optimized for multiscreen rendering” don’t do anything to solve this.

3.) System scaling does not work. (not sure if this is related to Optimus?)
As soon as I put a renderer to Fullscreen and back > the scaling options of the OS as well as the V4 GUI get’s scrabled.
I found a thread which points out a registry entry called MAXIMIZEDWINDOWEDMODE. This entry just keeps coming back when deleted and resetting itself to 1 when put to 0.

Any ideas?
I really hate to send this machine back.

I don’t think it’s optimus related. I am currently tinkering with my new haswell macbook (the integrated gfx doesn’t show in windows so no optimus) and windows 8.1 looks rather nice on the retina screen. The only application not scaling correctly so far is vvvv. In fact it is totally garbled when setting the scaling higher than 125%.
But without scaling you’ll need a looking glass… Since High-Res screens aren’t going to go away, it would be really nice if the vvvv-gui could get some kind of makeover.

this is what a renderer and a quad look like

@björn:
That looks kind of what happens on my system here (but only AFTER I’ve put V4 into fullscreen once). After fullscreen the GUI looks like in your screenshot and the scaling is resetted to 100%.

Meanwhile I’ve installed Windows 7 on my system. I’m still not sure if I get all the drivers together, as DELL doesn’t provide other drivers than Windows 8.1 for this model. (I have to handpick them from the component manufacturers websites)
HOWEVER: The system forced me to install both drivers: for the Intel HD graphics and the GT750M as well as Optimus and Nvidia Experience. Good news: simple single renderer in fullscreen mode seems to work now, even with Optimus in action (tested with the Optimus test tool).
Also the system-scaling doesn’t fuck up the V4 guy after switching to fullscreen anymore in Windows7, however, Windows 7 does not allow to have multiple screens in different scalings, so only solution for now is to run the internal display on a lower resolution when connecting additional screens.

It looks a bit like Windows 8.x, V4 and Optimus are no good friends all together.

Just found out how to “reset” the gui. Right-click on vvvv.exe -> Properties -> Compatibility Tab -> untick “Disable display scaling on high DPI Settings” & apply. Unfortunately this gets ticked again when going to fullscreen.

edit: some reading for @joreg :)

http://msdn.microsoft.com/en-us/library/dd464659(v=vs.85).aspx

sounds all quite terrible. the only info i can offer regarding dpi-values is that vvvv should eat any value fine that devides 1440 to a whole number, like: 96, 120,…

The setting is stored in following registry key:

HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

I used ProcessMonitor to see what happens, when going to fullscreen.
Seems vvvv.exe is looking for this registry key and when it doesn’t find it, it will create it.

Okay, here are the news about problem 1 and 2 described above:

The fullscreen issues are definitely connected to Windows 8.x.
I got Windows 7 installed on this machine, including latest drivers for the Nvidia GT750M and the internal Intel HD graphics card. Optimus is up and running, according to the Optimus Test tool, that shows which graphics adapter is used. V4 is set to the GT750M in the Nvidia control panel (as suggested by gegenlicht).
I connected a Matrox Triplehead to the MiniDisplayport … this runs 3 screens on 1280x1024 … and an additional screen to the HDMI port which runs on 1920x1080. … 4 screens in total connected, which run two renderers in fullscreen (3840x1024 and 1920x1080). No flickering, everything fine.

BUT: It’s not possible however to have more than one renderer together in windowed mode on either the internal or one of the external screens. In this case both renderer either freeze or feature alva-notoesque glitches.

The Nvidia control panel presents an option to either optimize for multiscreen setups, compatibility mode or single screen setups. This option doesn’t change any of the described behavior.

continued: https://discourse.vvvv.org/