Nullable Types VL

I’ve imported a dotnet library and some of its inputs require nullable types.

It seems that to so this I have to import System in its entirety and its isn’t clear how to do the implementation (in a script I’d just put a ‘?’ at the end of Type).

It loks like something best done under the hood.

Ideally this should be done under the hood by us devvvvs. However since this isn’t done yet: did you have a try of importing via type import?
In the end the Nullable type is just a type as any other, no?
So try this and maybe name the forwarded type “?!” if possible.

If you wondered what i’m talking about:
in the grey book the documentation about forwarding a type importing currently is found under “patching libraries” … and then “forward wrappers”:
Well, we are working on that part still…

Took a while to get it, but indeed CastaAs did the job. I initially I tried to actually import the type but I couldn’t understand how to create a type constructor in VL and in the end CastAs worked as an adaptor that I could use in the forwarded nodes.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.