Nuget wont install from disk

hi all,

I downloaded a vl nuget from patreon and tried installing using the installation commandline


but I get the following error:

is there something wrong with the nuget or is this 5.x related?

What if you point to to the directory that contains the nupkg rather than the nupkg itself?

Yes. the source should be a URL or folder, not a file.

does not work either. I followed this tutorial doing it manuallyl: Creating and Using a Local NuGet Package

Could you show the command you have used and which error it returns?

ok, am I not allowed to load the nuget from C:\VL.HapPlayer.2.6.0.nupkg ?
I placed it in a folder on the desktop and the command worked. I am on another machine though.
sry I don’t speak nuget

Maybe there are some security restrictions when trying to run commands in C:\ directly. At least if the same command runs fine when the nupkg is on the desktop, it could indeed be a permission issue.

You can “just” unzip the package. Which will result in a folder-structure like that:


You’ll have to re-organize it to look like this:

If you copy the result into your nugets folder vvvv should pick it up.

The problem I mentioned above, occurred on two machines. On the next two it just worked. (Also when the nuget was placed directly in C:)

@bjoern thanks for the tip! I will try it on the next machine.

Slightly OT: If you are using gamma >= 5.0 ask @lev for the new player version. It is compiled for net6.0, has some fixes and also exposes features that allow to greatly reduce memory consumption.


is never a good idea, because you run into issues that some tools use recursive folder scanning, which would scan your whole hard drive. And it also has special security flags.

@schlonzo I’ve just updated the nugets on Patreon. Please take a look