Nrt writer depthbuffer problem

i build a beautiful scene with the box node. i want to render a nice movie using the nrt writer node.
the scene looks good in the render window if i set the depthbuffer to d24x8 but in the rendered images the boxes
always look like i turned the depthbuffer off. i tried different depthbuffer settings but none seem to work for rendering the movie…
is this a bug?
please help since i need to render a movie badly…
danke paul

halo paul. sounds like this thread. so maybe you could try updating your graphiccard driver.

yup, you need ati to render with depth buffer it seems, it worked with 1 driver version on nvidia I think, but no more :(

this sucks…
i have an nvidea gforce go 6800 ultra…in my laptop…
so i can’t just swap the card…

it’s been a while since i contacted dell for a driver update…
will try that tomorrow and let you know if it did any good…
cheers paule

Only other option is record to DV/analogue capture the output, but it never looks quite as crisp!


hey there i stumbled across the same problem.
i have a geforce 6800 go in my laptop and the depthbuffer
doesn’t work either when i use the nrt writer. in addition to that also the antialiasing doesn’t work with the nrr writer.
(i do have the latest driver)

i also have an older desktop with an ati radeon 9600 and the latest driver. here the depthbuffer works with the nrt writer but the card doesn’t seem to support antialiasing at all.

so does the depthbuffer + antialiasing work with the nrt writer ? with which card ?

any suggestion?
how about the Radeon X1600 PRO ? it must be an agp card since my desktop isn’t brand new…

thanks jannis

halo jannis.

antialiasing does not work with DX9Textures. this is by design. by ms-directx. you have to options:

  • write out the images twice as big as you need them and scale them down to achieve some smoothing.
  • eno told me he modivied the nrt-writer so that it uses the screenshot node. the disadvatage here is that you need an open window showing the antialiased rendering. on the other hand you don’t need the scaling-step and also have the depthbuffer included.

lets all ask eno to release his module. EEEEENOOOO…

thanks joreg…
the eno aproach sounds like a good deal…
if i get it right then this solution should work
with a nvidea card, too.

please eno, release that thing !
cheers jannis

hey joreg…
i just patched it myself…

thanks for the inspiration with the screenshot node. i wasn’t even aware of its existence.

so here comes the module. just drop it in the modules folder.
Writer (EX9.Screenshot NRT).v4p

Writer (EX9.Screenshot NRT).v4p (28.0 kB)

This doent seem to work for me, the renderer is selected, the writer says its saving frames but nothing is saved, when I connect a quad and renderer to the screenshot node I just get a white quad,
any ideas?


does the Screenshot (EX9.Texture) node work for you at all? maybe a problem non-power-of-two dimensions of the screenshots texture.

No it doesnt seem to, do I have to manually set the renderer to 1024 square or something?

you can set the width and height of the screenshot node in the range of 0 to 1 relative to the desktop size. open tty and change width/height on the node. if that is the problem it will spit out errormessages until you hit the right dimensions.

That does it!
Intrestingly it seems to be much faster than writer nrt!