Not working some texture filers, why?

Hi everyone!
Not working some textere filters. For example glow and twirl. Why?
Addonpack is in vvvv-folder, all checkboxes are green. On another computer all good.

Hey funkypanky!

Can you provide some further details of your setup? Like what vvvversion you are working with and maybe attach your patch to this post? This will help finding the problem =)


P.S.:Oh, almost forgot - can you also post a screenshot of what the TTY Renderer has to say? Thanks!

Hello,dl-110!I apologize for the wait, I had crunch time on my work.
Here is additional information:
I use this version of vvvv.

Here is my pc characteristics:

Here is my patch, simple test scene.
PS: im novice in VVVV, how must i setup TTY Render to obtain the desired information?

GLOW.v4p (3.4 kB)

No worries!

And thanks for the additional info. I added the renderer-(tty) to your patch. Can you run it and post a screenshot of what the TTY renderer has to say? And for your information - the TTY renderer is often used to debug a vvvv patch. It shows all the underlying actions of vvvv and displays what it does (or tries to do). Open the patch and then you’ll see what I mean =)
You can add the tty renderer by typing ‘renderer’ into the node browser and then select Renderer (TTY).

GLOW patch from funkypanky with TTY Renderer (3.6 kB)

@dl-110: Good shout on the TTY renderer. It sounds like there might be something wrong with your RENDERER settings OR your DX9 Texture node settings, click on both nodes and go in HERR INSPECTOR to see the node setting/properties, you might need to change some of those hidden pins settings… Cheers

Here is my TTY render log information and texture settings:

Here is my render settings:

Open image in new tab to enlarge.

Logs are ok.

Is rightmost pin (of glow node) called Enabled, well, enabled? Does it shows a hint Enabled: 1 if you hover the cursor there? If it’s Enabled: 0, then turn it to 1.

Fuck I’m at work I ain’t got vvvv here amigos, I got a feeling it might be something to do with you DX9Texture setting… Can you post a screenshot of your dx9texture settings in herr inspektor?

@h99 Yo bro how goes it? Nice reply on the other thread I will be in touch via email bro, let’s nail this.

If you right click on the Glow, you open it as a module, and you see the mess that is the Glow, now, you see a few times the Glow Shader, and that has an output pin called “Technique Valid”, if it works, it is ONE, if your gfx card doesnt support it, it is ZERO, (my cheap netbook is zero) and not much you can do I think, except upgrade to an nVidia Card, or rewrite the shader so it works on your ATI. :/

h99, yes glow is enabled - value:1

evvvvil,hi! here is DX Texture settings:

Westbam,Technique Valid is 1.

May be my graphic card is not support this stuff? but it’s no singular effect which not work. Twirl effect not work, and bump effect.
May be problem is addon installing?
i simple put addon folder in root of VVVV, without replacing files.
When i merged folders from addon(girlpower, lib and licenses) with same VVVV folders and accept with replacing files,then some stuff from addon not work. Where is true?:D

Well, first thing: why you have all those non-vvvv folders in there?
Clean it up or reinstall vvvv, and check if it works.
Just to mention: glow’s pins values are not zero, no?

h99,glow’s pins values are not zero, it is 1.
Non-vvvv folder are my texteres, models and projects folders.
i tried to delete and reinstall VVVV and addon pack -same result.
Did I understand correctly? Should Addon folder be in the root folder VVVV? like that?
May somehow affect checkbox “DirectShow filter” to display effects?
P.S.:strange result - i install VVVV and addon pack on my netbook, not notebook!)
Twirl effect works there, but glow effect not.
Why twirl not works on my notebook?)) it has more higher parameters then my netbook.

That all is strange indeed… I’ve never encountered a problem like that in vvvv. And it shouldn’t have anything to do with the addonpack (which you installed correctly by the way) and your crack.exe settings look fine as well.

How old is your notebook / netbook? Have you tried to update your graphic card drivers?

May be problem is in my graphic card.
I bought my notebook in 2009 or 2010 year.
Here is my model:

3D max,Blender,ZBrush works propertly on my system, and also all adobe programm works good.
I think VVVV is critical to graphic parameters.

I think your notebook should be more than sufficient funkypanky. However, my guess is that it has something to do with your system (specifically the graphics card) and not vvvv. I would try to update the graphics card and maybe contact the author of that node and ask him for help?

@funkypanky: did you try opening the renderers inside the glow module? to see where it actually stops working.
you might also want to try setting the Format on the DX9Texture (EX9.Texture) to X8R8G8B8. this is about the most default format which should work on any card

Another thing to try: Open the module and delete Info (EX9.Texture).

Woei,i tried to setup DX9Texture(EX9.Texture) to X8R8G8B8.
It no works.
bjoern,i tried also you metod, same thing…
i also tried to detete catalyst amd software and graphic drivers and reinstall drivers once more- nothing happens.

But i found interesting thing - when i open glow node and set technique pass
from 1 to 2 in second block - glow becomes visible , BUT glow shape, glow amount and glow radius not available.
Twirl effect not works with any technique pass in its node, and BlurGlow too.

Perhaps ATI drivers not compatible with something…

please run this patch and take a screenshot
do any of the texture filters actually work on your machine? which ones?

Twirl_Debug (EX9.Texture Filter).v4p (29.1 kB)

Here is screenshot of Twirl_Debug:

I also test almost all texture filters, almost all works except of some filters:
6)keying (not see changes, may be it works)
Here is pic of tested texture filters:

Open image in new tab to enlarge.