Not all nodes on Update are running

hello all,

I saw this weird situation where in my Application patch, an LFO would run just fine on Update, and other nodes also assigned to Update would show "No Data Observed’ in their tooltips. After deleting and recreating those nodes with CTRL + Z, and exception would be raised.


Repro steps :

  • Open gamma 2021.4 595
  • In a new patch, install this version of the Grapevine nuget : nuget install Grapevine -version 5.0.0-rc.8 (beware this will install a ton of dependencies)
  • Create an LFO
  • Try to repro their Getting Started example :


  • The Start node shows no timings
  • Delete it and CTRL+Z, this exception pops.

Here’s the repro patch :

NotAllNodesAreRunning.vl (4.6 KB)

Can provide more details if necessary!



Our system wrongly loaded the net5 assemblies causing all sorts of type load exceptions. Should be fixed in upcoming builds. Thanks for pointing it out.

Thanks for the update!

I ran into a similar issue today on latest preview (612), not sure if it’s related or not. I’ll open another thread if it’s a different thing.

I’m trying the new System.Text.Json nuget which has a net6 version. I tried to delete netcore and net6 assemblies in the package and its dependencies, only keeping framework and standard2.0 ones as a temporary fix, but soon as I create a node, the patch stops running without reporting any error :


Thanks in advance!


Hmm, looks like we’re running into a conflict here with the same assembly (but older version) already loaded by the MSBuild installation (C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin\System.Text.Json.dll). Getting rid of the dependency of VL.Stride to MSBuild is already on our list, so I guess you’ll have to wait on that one until you can use this package.

Noted, thanks for the insight.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.