Forum

No deinterlacing and crashes with cheater

Hi,

I’m experiencing issues using cheater node on Lenovo W520 with Nvidia Quadro 1000m. The node is working really good with Lenovo W510 ans quadro 880m but i need optimus for multi screen rendering. The issue is with any 3 different SD Dvr interfaces, those work great on the other computer with cheater and are deinterlaced.

Is it a know bug ? it there any solution ? i really need deinterlacing those cheap video grabbers on this computer !

Thx for your advice

RitoonL

i am afraid i don’t understand your problem. “i need optimus for multi screen rendering” sounds odd. are you sure? please try to explain better what your situation is.

yes, sorry for my bad english.

what i mean is that i absolutly need multiscreen (laptop screen + 2 videoprojectors) and i can’t do that with my W510, that’s why i’m using a W520 that can go up to 4 screens.

Maybe i’m mistaking with optimus but i heard it’s needed for more than 2 screens. Also, i don’t know if it can be related with my Cheater node issue.

Thx

RitoonL

hm… your english is fine but you’re not really telling us what your actual problem is. describe the technical setup. what works, what does not work. maybe even add a simple patch that shows your setup.

Ok …

here is the full description of my problem.

I’m capturing a SD camera with a low-end analog to digital video interface. This interface gives to the computer an interlaced signal that i want to desinterlace using the cheater node.

This is a small part of a big patch with 2 video renderers that will go on 2 videoprojectors for a theatre show. This patch is controlled by an DMX program (whitecat). The video can be used directly or injected in -bg+key.fx for a “green screen” like effect.

This work really great on my W510 and most of the patch is debugged and working smoothly. Also, the Cheater node works great and deinterlaces the stream. But the computer can’t enable more than 2 screens at the same time and i need 3.

That’s why i’m using a w520, wich is quite hardware similar except of the Video card (NVIDIA QUADRO 1000m). There i can have 3 screens, this work on the 2 videoprojectors for videoplayback. The laptop screen used for controlling the patch and whitecat.

But in this configuration, i have issues with deinterlacing. The cheater node don’t work and vvv crash when setting video in resolution to 720*480 wich is the resolution of my camera. i guess it’s an issue with the video drivers.

Also, i’m thinking that optimus could be the reason that the cheater don’t work anymore but have no clues about that.

The most annoying is that i can provide you a patch and it may work for you. I know that the patch is functionnal because it works on the W510.

is there another deinterlacing method than CHEATER ?

I already tried Dscaler but this one don’t work and give me a white renderer. Seems this one only work with 720*576 resolution.

Do you have any clues on how i can make Cheater working on this video card ?

Regars,

RitonnL

if you want to make your life much easier, buy or rent a triplehead2go.

if that’s not a solution for any weird reason, you should read the optimus related threads here on the forums…

ok, thx,

There is no budget for the Matrox and the multi screen works perfectly with the computer, i have no issues with this.

The problem is with the grabbed video that is interlaced.

As this is not the hardware that will be used for grabbing (there will be a blackmagic shuttle USB3 and a gopro). I need for testing purpose to deinterlace the signal with the testing setup i have now.

The blackmagic shuttle is reported to work with that computer, even if this device seems quite sensitive.

But for now i only have this cam and this SD grabber for testing and the budget will be unlocked if results are good enough with what i have.

i’ll read optimus related threads right now.

thx for your answer

RitoonL

i’d rather not recommend reading the optimus threads. they are long and no longer relevant to b32.

one thing you could try: instead of specifying the native 480 for the videos height specify 240. i remember that some capture-drivers then simply left out one field. while this reduces your resolution it could do as a test.

otherwise i didn’t really get the difference between those two laptops. i guess both have one displayport output?!

  • how do you connect the two external monitors?
  • is this on win7 or 8? or 8.1?
  • do you go fullscreen with one renderer over both outputs? or do you need 2 renderers?
  • if on the better pc you try with only one output (as you can to with on the other pc) does it then also work?

Joreg,

Thx for your answer

one thing you could try: instead of specifying the native 480 for the videos height specify 240. i remember that some capture-drivers then simply left out one field. while this reduces your resolution it could do as a test.

when running in 320240 the video in not interlaced but quality is not good enough for my purpose. Running 720240 seems not to change anything.

otherwise i didn’t really get the difference between those two laptops. i guess both have one displayport output?!

W510 has NV Quadro 880m, non optimus graphic card. It can only run 2 screen at a time
W520 has NV Quadro 1000m, optimus graphic card and can run 4 simultaneous screens (i only need 3)

how do you connect the two external monitors?

First one is connected to the built in VGA port, second one on Display port regardless with VGA/HDMI adapter cable.

is this on win7 or 8? or 8.1?

Windows 7 64bits

do you go fullscreen with one renderer over both outputs? or do you need 2 renderers?

There are 2 renderers, one for each external screen. The go fullscreen all along the show. This part of the patch works perfectly and smoothly, no frames dropped.

if on the better pc you try with only one output (as you can to with on the other pc) does it then also work?

Cheater always fail ont this PC whatever the number of screen connected. under 720480 it don’t crash but don’t deinterlace, also the selection of deinterlacing method is messed up in the videotexture node. I tried with a minimal patch to debug and it’s the same, only running with the laptop screen. VVVV crash as soon as i setup video in on 720480. I also tried with 3 different USB grabbers, same for all. All of them work correctly on the W510 with cheater node attached and are deinterlaced.

Thx for your help

Regards,

RitoonL

so if on that pc you only do a simple patch with videoin->cheater->videotexture->fullscreenquad->renderer only it also does not work?

yes, the cheater fails or crash if in 720*480

the same patch will work on the other computer

and just video at full size without the cheater…that works, only then of course is interlaced?

how exactly?

D’oh i can’t reproduce this one ! but after a few tries, i experience weird things.

Starting a test patch with no cheater, everything is OK. then i patch the cheater. The stream works if under 720480 (if 720480, VVVV crashes), but it’s still interlaced. Choosing an interlacing methods makes the renderer black except with edge filtering (but it don’t deinterlace) any Bob method gives me a black renderer, even when i choose no deinterlacing again.

removing the video texture and repatching a new one the video is re-appears but same symptoms are still there.

I also tried to disable Optimus in bios, just to check if it had something to do with that bug, but no results, it’s exactly the same. So i turned it on again.

and just video at full size without the cheater…that works, only then of course is interlaced?

Yes, sir

Regards,

RitoonL

hm…then i am afraid i don’t really have an idea.

i guess it might be Nvidia drivers related, but i’m up to date :(

Any idea about how making Dscaler work ? i installed Dscaler but it’s still not working. I read that i need to move the DLLs somewhere in VVVV but don’t really know where !

As Dscaler moved their homepage, did i install the right stuff ?

http://deinterlace.sourceforge.net/downloads.htm

Do i have to start a new thread about that, or can i continue there ?

for dscaler to theoretically work you’ll have to:

then you can see if it does something.

thx, i’ll try this on both computers.

Regards,

RitoonL

Ok, i have results on both computers !

with the dscaler, the video signal is deinterlaced \O/ there are a few artefact left but, that’s the best i had with this computer. Even if that was a bit better with cheater on the other comp. This will do the trick for demonstration i have to do for now

In fact the topic is not really solved and it’s frustrating not to know the reason why cheater do not do its job. but, thanks to you, i got a working solution.

Thank you very much, you were very helpful, my friend !!!

Regards

RitoonL