New laptop - massive fps drop with more than one dx11 renderer open

New laptop - MSI with GTX980 ‘desktop’ level gpu

v4 runs well, but if I have more than one visible dx11 renderer, the framerate drops (even with an otherwise empty patch)

dx9 renderers are fine

any idea?

anyone have an idea about this?

seen it before?

Yes, I’ve noticed dx11 multiple windows runs slower even with no geometry in the renderers.

it’s particularly bad with this laptop though. as in unusably bad

vvvv is assign to the gpu in the pref’s its not using the built in gpu?

yep (only has main gpu afaik), and performance is great with one renderer

ive had problems with a preinstalled MSI Game - Capture/Broadcasting Software/Driver…

hope this helps, for me it was painfully annoying to find the issue…

the only screen capture tool I can see is a part of the overclocking app ‘Afterburner’. Does that sound right?

cant remember the name but it was official… so i would just try uninstalling it

found something called game cast blah something in installed programs. Think that was it (got rid of afterburner at the same time, though might try adding that back)


Glad i could help! Game Cast blah sound about right…

its very annoying that these programs look like parts of the drivers… makes it really fun to spot ;X

Sorry for OT, but did you get that laptop for VR? If so any feedback?

I didn’t but what do you want to know?

Am happy to run some tests if you like.

It’s great so far. Seems basically as advertised. GPU is great.

On the downsides - big, heavy and garish! But still way more portable than any other power setup.

It’s one of these

Hey mrboni,

It seems I’m facing the same bad surprises that you had with a brand new MSI GT72…
On my side it’s not “unusable” bad, but quite “worse than the old laptop” bad :)

I’m not even trying to have 2 Renderers at once, but play the simple “empty renderer / PerfMeter” test and I hit 30/40fps most of the time.
I tweaked all the usual GPU settings properly (max performances, always use the GPU etc.) in the power savings and Nvidia settings; and ensured it was a perfect replica of my settings on my old one (Asus ROG, running 120fps smoothly).

I got rid of all the bloat ware I found, the afterburn / game cast / gaming blast-o-tron 2000 and other crap, but nothing does it.

Actually in my multiple exotic tests, I noticed that if I launch my test patch on the laptop (with no monitor plugged in), then plug in my second screen, the renderer can infinitely be dragged from one to the other while hitting 120fps on the second screen, and 30/40fps on the laptop’s.

I can easily look at the usual suspect #1, good ol’ Optimus, but am curious if you remember having tweaked anything else fancy to get it reach the expected perfs?

Latest nvidia drivers, latest Win 10 update just done, no change.

Thanks a lot if you have a sec for your feedback!


Well that’s exciting:

After double-checking any possible video-related suspect, I just found out that the guilty one was “Nahimic for MSI”, some apparently AUDIO-oriented bloatware. Not where we instinctively pay attention to, but probably some directx involved there, not so surprisingly after all…

Toggling it on and off immediately shows the perf jump; that’s repeatable and systematic, even with laptop reboots in between:
– Nahimic on (process is launched on start up by default): 30 or 60 fps (can’t really spot why/when between the two)
– Nahimic off: 120 fps

Sharing this for any other desperate soul in the future


1 Like

good sleuthing!

Thanks for the great info TremensS. Just a bump here to remind anyone getting an MSI machine, had the same problem with another lappy. Also Ant was saying he’d come across it on one of their desktops too. Nixing Nahimic indeed seems to fix it.

Hi guys, tell me pls, when i can buy a laptop, pls i need verified shops, what about verified