Forum

.net 4.0?

Any chance of moving to the .NET 4.0 runtime?
My experiences with migrating existing codebases to 4.0 have generally been very simple.
I don’t know exactly what your runtime hosting (on the native Delphi side of things) is like, so that might require a bit of work.
…it would be really nice to be able to use the DLR, covariance and contravariance, etc.

we wanted to, but came to the conclusion that it’s probably still too early to use .net 4, since we had very strange crashes when running with a debugger attached. and only a debugger using the managed debugging api. running without a debugger or only an unmanaged debugger like the delphi debugger everything worked fine.
i think i spent nealry an entire week trying to narrow it down, but sadly no luck…

are you referring to the Visual Studio 2010 debugger?
i’ve been using that do debug plugins with the current release of vvvv (using the 2.0 runtime, etc), and i’ve encountered some strange crashes (stuff like all keyboard input and mouse clicks being blocked by something so the only way to get out of it is to use ctrl-alt-del and log out).
it’s possible that the issue is with the debugger and not the runtime.

the vs 2010 debugger, the sd 4.0 debugger or simply the clr debugger shipped with the .net 4 sdk. they all use the same debugging api and starting the unmanaged vvvv application which loads the clr 4.0 during startup results in a corrupted heap. vvvv dies slowly after doing some stuff, like creating a few nodes etc.
note that when we simply attached to an already running vvvv process (which loaded the clr already), everything worked fine. so my guess is that something must be going wrong in the debugging api when the clr 4.0 starts up. switching back to clr 2.0 and everything worked fine again, but of course assemblies need to be compiled for .net < 4.0.

and the problem you’re referring to is something we live with since windows vista ;) but i think that’s an issue caused by vvvv and not visual studio. really really sucks, i know.

@thezer0ist: crash you talking about happens only W7-64 but really constant, you can use TASKKILL /F /IM vvvv.exe as bat somewhere

@antokhio: i’ve encountered it in both win7 x64 and vista x64.
unfortunately since i can’t use the mouse or keyboard there’s no way to trigger such a command. i’ve generally kept process explorer open with a “do you want to kill process vvvv.exe?” prompt up so i can occasionally manage to click the button before the mouse stops working.
i’ve vaguely pondered the idea of making some sort of monitoring program that communicates with a vvvv node via remoting or a shared mutex or something and kills the process if the node stops responding…

concerning the stuck keyboard and mouse we are aware of the problem. it is related to our way of using mouse and keyboardhooks that worked on win2k and xp and are now causing trouble under vista and 7.

what worked for me some time was as sapo also suggested in the shoutbox: open a text-editor and when logging off (on being stuck) windows will ask you to save the document, which you can cancel and you’re back in the game (if vvvv was already shut down).

another thing was this https://discourse.vvvv.org/t/5966 i’ve provided some time ago. maybe that improves the situation…

still of course no real solutions…its on our todo.

that’s not only reason why i use total commander…