I am having trouble connecting to my database, I have wamp running and have created the database, set the password to the same, but it still wont connect, just gives me the following:

2003 Can’t connect to MySQL server on ‘localhost’ (0): Could not connect to mysql server using:
User: root
Please check the following:

MySQL Server is running on the host and port specified and that you can access it through possible firewalls
If the server is available and on a remote machine, check that this username (with password) may access it from a remote IP, see MySQL Manual (Security)

I have tried changing the port in

$cfg’Servers’$i’host’ = ‘localhost’; // MySQL hostname or IP address
$cfg’Servers’$i’port’ = ‘’; // MySQL port - leave blank for default port
$cfg’Servers’$i’socket’ = ‘’; // Path to the socket - leave blank for default socket
$cfg’Servers’$i’connect_type’ = ‘tcp’; // How to connect to MySQL server (‘tcp’ or ‘socket’)
$cfg’Servers’$i’extension’ = ‘mysql’; // The php MySQL extension to use (‘mysql’ or ‘mysqli’)
$cfg’Servers’$i’compress’ = FALSE; // Use compressed protocol for the MySQL connection
// (requires PHP >= 4.3.0)
$cfg’Servers’$i’controluser’ = ‘’; // MySQL control user settings
// (this user must have read-only
$cfg’Servers’$i’controlpass’ = ‘’; // access to the “mysql/user”
// and “mysql/db” tables).
// The controluser is also
// used for all relational
// features (pmadb)
$cfg’Servers’$i’auth_type’ = ‘config’; // Authentication method (config, http or cookie based)?
$cfg’Servers’$i’user’ = ‘root’; // MySQL user
$cfg’Servers’$i’password’ = ‘password’; // MySQL password (only needed

just a thought, isnt it that

3306 is the default MySQL port number

The default MySQL port number is indeed 3306 and normally there is no need to change it. If you want to change it nonetheless you should pick a port which is not as common as port 80. Port 80 is amongst others used by webservers (like the apache http-server) or Skype. If you have software using port 80 running on the same machine it is most likely that the MySQL-Server can not bind the port and therefore won´t work properly.