Forum

MySQL / Database node

Hi everybody,

I’m a new vvvv user, and I try to use the Database node in order to control a solenoide by a php web page.

I try to make something like that :

On clic to a button in the web page --> It change a value in a database --> Then I upload this value in vvvv thanks to the Database node --> And finally I control my solenoid with an arduino.

I dont understand why but I cant connect the Database node to my database, I fill the pin one with my server name, the port pin : 3306, the third pin : my database name and , then my username and my password. An finally I connect the node.

Is there something else to do?

Or do you now an other way to realise this project?

Thanks for your help,

Rogerlette

I have understood my problem, It’s simply my free host which not allows the external conection to the database. I need to use his web interface…

So, I will change my host ! Anyway, If you know any solution which dont use database I’m interested…

vvvv itself can serve a site. have alook at the help patch in the folder:
your_vvvv_directory\girlpower( web interface )

hi , thanks tonfilm , i tried the web interface already but i can make it to work ,
i basicly need to get a value from the website to vvvv , what is the best way to do that
i can not understand the patch sorry ,

in url where it says myPatch.vvvv i should put http://mysite.com ?

I,d like that the values are changed by any user so they will not need a password how do i do that ?

in the folder sources i tried to open colorPickerAdv but does not work , how could i test thsi locally i,m lost

is there a example website where to test this ?

hi rogerlette,

i remember having had issues with that patch also.
perhaps you try the version i attached.

start the help patch and open

http://localhost/myPatch.vvvv

in your webbrowser. allow javascript.

now enter some values on that website and submit.
you see that you changed the content of some ioboxes in the helppatch.


but perhaps you simply want to parse a website for an information.
check the WeatherReport-Patch at kalle.Patches, perhaps its closer to your goal.

WebInterface.zip (55.8 kB)

while chatting with rogerlette to find his problem,

we found out that @david wonderful webinterface seems to collide with SKYPE.

quote from chat:

try the following:

*really,really quit skype (rightclick that green V in the your taskbar)
*restart vvvv
*create a Renderer (TTY)
*start the WebInterface helppatch.
*look for the messages in the Renderer (TTY)

while running skype i noticed
00:00:23 - : Could not bind Socket on Port: 80

without running skype i didn’t have this.

if you have that message also without skype, try to close every program which may try to access port 80.

btw:

once the patch is running it seems to be no problem to use skype again…

or just use a different port for the webinterface…