Multiple TexCoords from Collada not working

Hi there,
I want to use 2 TexCoords from a Collada file in the Shader like so (There are 3 TexCoords in the .dae, since I wanted to make sure I didn’t mess up something in one of the UV Sets)

vs2ps VS(
    float4 PosO: POSITION,
    float3 NormO: NORMAL,
    float4 TexCd0 : TEXCOORD0,
    float4 TexCd1 : TEXCOORD1,
    float4 TexCd2 : TEXCOORD2,
    float4 vW : COLOR)

but anything beyond TEXCOORD0 seems to return zeros. I tried both the default dae and OpenCOLLADA exporter for Maya 2013. The additional TexCoords are in the files (I checked with a text editor) and show up if I import them back into Maya (images are attached).

I also tried changing a part in maya_hexGRID_F_09_COLLADAMaya.dae from

<input semantic="TEXCOORD" source="#polySurfaceShape1-map1" offset="2" set="0"/>
<input semantic="TEXCOORD" source="#polySurfaceShape1-uvSet" offset="3" set="1"/>
<input semantic="TEXCOORD" source="#polySurfaceShape1-uvSet1" offset="4" set="2"/>


<input semantic="TEXCOORD0" source="#polySurfaceShape1-map1" offset="2" set="0"/>
<input semantic="TEXCOORD1" source="#polySurfaceShape1-uvSet" offset="3" set="1"/>
<input semantic="TEXCOORD2" source="#polySurfaceShape1-uvSet1" offset="4" set="2"/>

but that didn’t work.

Is this a limitation of the ColladaFile Loader? Or vvvv? Or am I doing something wrong?

I’m using vvvv 45beta30.2 and tried both in VMWare with WinXp and Win7 on a PC btw.

Thanks in advance (1.5 MB)

Elias fixed this for me a while ago, at least for two UV sets that was.
Can’t imagine that this version hasn’t go public yet … I was also loading two UV sets with the SDK’s current ColladaLoader just today. So it’s definitely in the latest codebase.

woei came up with some nice new features which I’m pretty sure are going to get pushed to the SDK, but these didn’t address UVs.

So the issue seems to be something else, can’t check right now, but I could compare your file to one of mine tommorrow.

Please, this was my first time using Maya for something other than just converting/exporting, so that’s likely the culprit.
By the way, what program did you use to create/export your meshes?

Edit: I just checked with the latest alpha and it has the same problem. So it has to be either the mesh or the shader.

Hmm … looking at the SDK commit history it seems the aforementioned changes weren’t pushed to the SDK.
Wonder what I’ve been looking at today then? … stay tuned, will investigate tomorrow.

(using 3ds max)

peeking in github it seems like the ColladaSlimDX.dll in vvvv-sdk was not updated after the texcoord fix.
dll in vvvv-sdk - changed 10 months ago
source in ColladaSlimDx - changed 9 months ago

Did you re-implement this fix without me knowing it? ;)
Because I just checked, and I get a second set of UVs.

seems like it … inconvient, me thinking it was part of the official release.

like woei said, seems i forgot to checkin proper ColladaSlimDX.dll - will be fixed in upcoming alpha.

as a workaround for now i’ll attach the lastest version of the library (143023a3051511f9135bb742a18eda9e1b22ea58). extract appropriate version (x86/x64) of it to your lib/nodes/plugins folder (overwriting the existing one). (75.8 kB)

Cool, thanks!