Forum

Multi Render trouble

I was wondering if anyone came up with a solution to this issue?

what “can” help in simple setups (only few renderers) is fiddling around >with device (ex9 manual) and the renderers device setting…

could you explain a bit more please sebl?

I have the same problem with two different machines with Optimus enabled gfx cards on win7 64bit. I use a daisychain of renderers for effects quite a bit and its important to be able to view them simultaneously.

There is no access to disable Optimus from the Bios on my machines, and if I disable the IGP from device manager in windows, I do not see any output on ex9 renderer.

Thank you.

i had such a optimus powered™ notebook in my fingers only for one hour a while ago.

we tried to have 2 renderers on one (main)screeen without flickering/switching between them.

so we played with the device setting of the renderers (you can only see in inspector). per default it is set to -1, what lets vvvv devide all the device stuff (i think). as i remember now, we tried something like 1 and 2.
that seemed to be stable, but we had no luck with more than 2 renderers…

i can’t reproduce the bug here, but using manual devices really to me sounds like the last thing to try…

just to be sure:

  • did you already play with all the Presentation Interval, Windowed Swap Effect … pins of the renderers?

  • after that i would suggest gambling with Device (Auto) first. As you know you typically don’t need to care about devices: you just create the renderers and directx devices are created for you. often renderers share one device, all this is done automatically. for changing properties of all those automatically created devices use Device (EX9 Auto).

So but you did actually create two different devices for the two renderers that are on the same monitor? That sounds really troublesome. You would need to go to each renderer and point to that manual device by choosing its device number… this really shouldn’t never be necessary.

well i posted huuuge anti optimus petition on nvidia forums, i think it’s survived for a day, then admins killed it. crap intel in crap geforce suxxx
but as i know it’s vvvv problem, my 630 in lappy flickers like hell

ps had same in 3dsmax untill switched viewport to 11

I think i found a solution for this old but still annoying multi renderer flickering issue within vvvv without the need switching on the stupid Aero-thing.

At least for me (Dell XPS L502X / GT540M) using Device(EX9 Auto) and setting Vertex Processing Mode from “Pure Device” to “Software” did the trick … no flickering using two Renderer.

Can somebody else check/confirm if this is also solving the problem for others … what could mean that this might be a general solution for the problem ?

Markus

@Msberger
Confirm with Device(Ex9 Auto) set to ‘software’ no flickering problem using more than one render
Thanks for the trick

DELL XPS 15Z with GT 525M

Sorry for bringing up this topic again, but…
…when I set “Vertex Processing Mode” of Device(Ex9 Auto) to “software”, rendering becomes very slow (which actually is to expect from software rendering, right?). Also some shader functions stop working.
So either I didn’t understand the trick or I wouldn’t actually call it a solution.

just wanted to update this, ive had it fixed at some point but the flickering is back.

The good news:

In the DX11 built flickering will only happen in windowed mode.
In Fullscreen everything is working fine.

Windows 8, Dell XPS 15 Nvidia 640M

It’s been more than one year now… The topic is still open…
Any hope this problem will be solved at some point? Almost any (if not all) current notebooks with nVidia graphics card are equipped with Optimus now.