Movement tracking that creates particles

hi again
Thank you for your kind answers.

i hope its ok to ask, but i have some silly questions which i cant seem to find a solution to.
so i decided to try it anyway, and see how far i can get .better anything than nothing at all, or at least i’ll learn some things.
i have a simple webcam. and its on.
i thought maybe the next step would be to figure out wethear its possible to track a movement on the screen, but i couldn’t figure it out. is it? any ideas?

thank you again, really

hi @ayalala,

with your webcam try Trautner node and other video tracking nodes in

there is also extensive image processing pack available

try the following particle contributions (both need DX11 pack )

Hello ayalala,

did you managed the project? I want to do the same and now starting to patch.
And thanks to all the great answers from the other guys.

Best regards

Hey guys, maybe someone can help me. Like mentioned above, I just started with the same project.
So far I have a video input (webcam and HAP video) running. Then process it through FrameDifference( from CV.Image Pack) to GridView and then to the Renderer (everything in dx11 on x64).
The result is nice but now I have no idea how to spawn some particles on the frameDifference result.

In processing or another language I would do:
look at all pixel -> if color changes for longer then 500msc then spawn particle on XY position on actual pixel position.

I tried to get the values with pipet(CV.Image Pack) but somehow it runs the fps in hell (5-10fps).
Is there a way to do it with vvvv nodes or do I have to write shader (what I really dont want and cant).

Maybe someone could give me a hint in the right direction. I`m new to vvvv, but I have some background in Touchdesigner and Processing.

Best reagrds

I am curious too. please let us know!

ok, got the first sketch running with cv.image pack.

brief overview:
videoin(cv) -> framedifference(cv) -> contour(cv) -> get vector data from contour and feed the emitter with it.

you dont have velocity, but its a nice starting point.

if someone wants the code i can share.

@neoshaman : I will try and get back to you. As I am new to particles, it could be nice how you’d manage it. thanks loads.!!!

this is my code so far. please note that i just started with vvvv one week ago. i’m a total beginner and many things are not perfect in this sketch because it’s still in progress
need: dx11.particles & cv.image pack.

if you can`t see anything, try to zoom out with the camera (did’t managed the best setting for cam yet)

particleTestForum.v4p (27.6 KB)

hi there, I tried your patch, but with 50beta35.5 x64 it doesn’t work. your patch makes app quit.
what version of vvvv did you use?

I use 50beta35.2_x64

Nope. Not working. I don’t why. I don’t understand what I am missing.
the cv.image and dx11 particles are installed. But whenever I open your patch, it’s calling out Visual. and from there it doesn’t go anywhere…
tried to write the pacth myself, but no success.
that’s getting frustrating… :’(

Hmmm… that sucks. I tried to comment my sketch and took a picture.
Hope that helps.

I changed the computer and went to an other one.
then the patch opend without a break.
but some nodes are missing.
As you said here, the nodes are existing in the file, but stays red. So I tried on both x86 and x64.
But still missing. how did you solve that?

and thanks for the screen cap!

Hmmm… maybe missing links in the root patch. And also have a look here.

In the picture you can see my links in the root patch.


Just updated vvvv and some CV nodes are not working (AsImage , AsTexture, GridView,…). Looks like the CV image pack is not supported in the 50beta35.5 x64 !?!
Does someone have more information about it?

Ok, I am relieved. I am also on 50beta35.5 x64
so I am not the only here.
let’s wait that somebody answers!

It depends on the dx11 version. It looks like some versions don’t like some CV nodes (AsIamge, AsTexture). For me the latest version from here works fine. But it’s a mess, don’t really know why it works. Just moved around some dx11 versions till it worked.

Is there any way to check which build of dx11 I’m using at the moment?

the dx11 pack had some internal changes on resource system, so all stuff that used it, such as textures and layers, now broken for some contribs

try to get 0.7 dx11 pack from git, maybe it will help you…

tried with the latest version of @neoshaman, and 0.1 of @antokhio. still nothing. nodes stay red.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.