Forum

Mouse Devices Window Node Red

Hello there,
I experienced a strange problem lately. My Mouse (Devices Window) Node is red and not working, while the Mouse (Devices Desktop) node works without a problem. I experienced this problem only with the latest stable beta40 release. I already reinstalled a fresh new beta40 and tried it again, but without success. Has anybody had the same problem?

hey there,

no issue here with b40, does Renderer (TTY) say something special?

Hey @sebescudie
This is what Renderer TTY is saying:

00:54:34 ERR : Exception occured in TMPluginWrapperNode.Evaluate
00:54:34 ERR : COM object that has been separated from its underlying RCW cannot be used.

hey,

kinda hard to tell with such an error message, does the latest beta preview show the same behavior?

@sebescudie tried out some stuff and beta40 is not the problem it seems. I have the same problem with the beta 41 preview, but only whenever I open a saved patch or a helppatch. When I begin with a blank patch and add a mouse or keyboard node it works until I open a Helppatch or a another saved patch and then I get an application error:

“There was an error during the execution of this program. The application might become unstable and even useless. It’s recommended that you save your work and close this application. COM object that has been separated from its underlying RCW cannott be used.”

From then on the mouse and keyboard nodes do not work anymore until I close vvvv and restart it with a blank patch.
However everything seems to work fine with beta39 or beta 39.1.

hey there,

just tried saving a patch that uses Mouse (Device Window) with latest beta preview and re-opening it after closing vvvv, no trouble here.

just a stab in the dark: could you try opening your patch via the command-line with the /logstartup argument as described here? maybe something interesting will show up…

also, could you repro this on a different machine?

Hey. I also have problems with the Mouse (Device Window) if I use versions after vvvv_50beta38.1. The problem doesn’t always arise. In my case (vvvv_50beta40 installed) the node works without problems starting from scratch or within almost any patch but it stops working in some cases. For example if I use the Mesh Editor the error is systemic.

Seems to be exactly the problem I have. It works on my machine as well if I start a patch from scratch, but if I open a saved one it’s broken. Haven’t found a solution so far…

Same issue, fresh install of beta40 today. In a new patch after starting vvvv, Mouse (Devices Window) works fine. Opening any of the example files causes the issue as described above, breaking both Mouse (Devices Window) and Keyboard (Devices Window). It might be helpful to mention that Mouse (Devices Desktop) and Keyboard (Devices Desktop) continue to work fine.

Edit: I work with Arduino boards, and occasionally my computer will loose access to the COM port a devices is plugged into - manifesting as a permissions error in the Arduino console. The only fix is to either reinstall my virtual COM drivers, or simply restart the computer. Its suspicious that vvvv is also having issues with COM devices. I might have some larger underlying problem with how COM devices are managed on my PC.