Forum

MJPEG stuttering, FPS, Hz, videotexture


#1

Hi guys,

I’m doing a live performance and mix live PAL video from a IDS falcon quattro with prerendered footage, MJPEG codec, 1280x720 @ 25fps.
Perf meter says it’s not the workload.

I’ve read about the hz problem concerning the videotexture node.
my card just lets me set the refreshrate to 60hz.
regardless if single monitor or spanned desktop.

I have one GTX 8800 with a monitor for preview a projector for output.

with the framegrabber deactivated, fraps shows 60fps on the output renderer.
no stuttering, altough i play the 25fps video.
when i activate the falcon card, the framerate drops to 50fps (palx2?) and i get light stuttering.

I tried encoding the video @ 30fps and setting the videotexture to wait for every 2nd frame, but then it gets worse. Is this impossible if i want to use PAL video?

yours truly,
schlonzo


#2

you tried setting to wait for 0 frames?


#3

yes. the renderer framerate is around 50 fps, sometimes dropping to 47, 48.

i don’t know what the problem is, since it runs totally smooth with media player.


#4

as far as i know, the videoinput is culprit for vvvv running on aprox 50fps (which sounds like 25fps interlaced). and i guess the jittering is also caused by the capturing rather than the filestreamed video.

you could try grabbing via the vlc plugin which uses an external thread.


#5

my desktop now runs in spanmode, 2560x1024 @ 75Hz.
i set the mainloop to 50fps

increasing time precision helped a little bit!
now the framerate does not drop that often.

@woei
how can i stream via the vlc plugin?
playback via the vlc texture is not smoother than filestream.

cheers


#6

@schlonzo: check vlcplugin helppatch. first input of the switch


#7

ok i found this old thread from 2006 here, which suggested setting the all videotexture nodes in the patch to 999.

framerate is now 69-72, totally smooth playback.

i don’t quite understand, but i like it :)
thx for the tipp using vlc, i didn’t knew u could use it for direct show devices.

good night