Missing patches (red nodes)


#1

Hi,

I’m constantly experiencing missing nodes (patches) with vvvv…
What is the best way to patch most effectively when this occures?

Thanks for help


#2

ai kundi, this is to vague for a question. you’d need to be more precise in your description. what are the steps you’re taking to get red nodes.

note that when hovering red nodes they tell you where (as a filepath) they were supposed to be but weren’t. that should always help you find them again.


#3

I opened some patch (Korg Nano Midi Map) for the second time and subpatches appeared red. I don’t know how to fix it.


#4

a red (sub)patch means that something inside of that patch is causing troubles (either a missing node or a missing enumeration). open the patch and follow the red nodes until you come to the actual culprit.

if it is a missing node, hover it to see where it is supposed to be found. if it is a missing enumeration, try to choose a different one (in your case with the nano midi map it is probably a device missing…)

if you need more help please try to be more precise in describing your problem. gut patch!


#5

Its actually a red node - missing … the path seems okay and the first time it worked fine, then second time I ran the patch I got them red…

How to fix that?

If I click the node with left, right, double click or inspect - it seems like I cannot fix it…

Thanks for help


#6

so whats the name of the node?


#7

The names of missing nodes are: MouseSim, SceneSelection, KorgNanoKontrolSimulation, …


#8

you could still drop some more words…

what i do:

  • downloaded korg-nano-kontrol-midi-mapper
  • extracted that .zip to the desktop
  • started beta26
  • opened Desktop\KorgNanoKontMIDIMapper\MIDI Mapping.v4p

and i see all the subpatches you mentioned (eg. MouseSim) in place and working.
so please make a precise step-by-step guide of what you do to get to the problem your facing.


#9

When I ran it first it worked fine, then on the second time I got this problem. The same happened with Svvvitcher, so I’d like to learn how to solve this and why this occures.


#10

the problem is this: unless you can consistently describe what you did to cause that problem we have no chance of helping you.


#11

Hello,

Sorry for re-open this old post, but I’m experiencing the same symptoms.

Whenever I re-open my patches or patches downloaded from the community, some random nodes are red. If I search in the vvvv folder for then, they are there, and if I open them individually, the previous patch that had the node missing, gets correct.

This is very weird. One that is almost always missing is the “Camera (Transform Softimage)” .

Am I installing something wrong? Is there a specific order to organize the folder structure?

On the attach is a print screen.

My system:
-OS: Windows 7 Ultimate x64
-VVVV: vvvv_45beta30.2_x86

Thanks in advance


#12

you forgot your attachment. meanwhile read this: nodes and paths


#13

error.jpg

Didn’t push the insert button

Here it goes

Tks for your time


#14

Hi guys, sorry have to warm this up again.
I do get the same issues frequently.
I built a very complex system now and sometimes the lates subnodes I changed appear red on reopening, allthough the patches are in the right place.

What I tried:

  • opening the missing patch - not helping
  • dragging the missing patch into the one containing the red patches - not helping
  • telling the containing patch to clean up links - not helping

I assume there is something wrong with the in/out nodes. Maybe it diddn’t save correctly (though I clicked save all). Any Ideas to fix this?

Image:

vvvv_45beta34.1_x64 @ win7 64bit

thanks


#15

Maybe if you try a different version of VVVV?

I had a similar issue yesterday…VLC DX9 didn’t work on 34.1 but it did on 34.2


#16

What follows is just for extreme caution.

Please

  • open the parent patch (the one containing the red node) with a text editor (notepad for example)
  • look for the node that is missing
  • check if the path is really pointing to the red node
  • for example
  • if parent.v4p is in D:\Folder and sub.v4p is in C:\Folder, you should find something like <NODE filename=“C:\Folder\sub.v4p” …>

  • else if parent.v4p is in D:\Folder1 and sub.v4p is in D:\Folder1\Folder2, you should find something like <NODE filename=“Folder2\sub.v4p” …>

This means that
if applicable, we will find a relative path.
If not, we will find an absolute path.


A workaround would be

  • save a copy of parent.v4p, and call it something like parent_1.v4p
  • open parent_1.v4p with a text editor
  • change the path to sub.v4p with an absolute path
  • open parent_1.v4p with vvvv
  • save it again
  • check what’s different between parent.v4p and parent_1.vp4 relatively to sub.v4p

A reason could be you moved parent.v4p from projekt folder to projekt\AnotherFolder, for example.


#17

we finally have proper documentation regarding red nodes that should answer some related questions.


#18

Hello vvvvlers,

I have the problem that I cant see the Trautner node from freeframes. When I open the help file, it says that the trautner.dll is missing. But it is in the right folder. After reading all help sites I decided to ask you guys. Really dont know how process further. I also linked the freeframes folder to the root patch but the error console still says that the dll is not there (but it is).???

Best regards
neoshaman


Movement tracking that creates particles
#19

hallo neoshaman,

freeframes nodes are not available in x64 builds.

cheers


#20

Thanks a lot mate!!!