Forum

Max Float Bug

re tiki-view_forum_thread.php?comments_parentId=13212&topics_threshold=0&topics_offset=4&topics_sort_mode=lastPost_desc&topics_find=&forumId=7

Thought Id better post it here, even if I feed the spread (range 0-1) into a min I still get MAX FLOAT, if I put a MAX node and it gets caught, so its big a negative, I’m now clamping it with a map node, but obviously its not the value I want! It doesnt show up in tty either
Cheers

Cat

After adding a map node to clamp, I get
00:04:52 * : [event.call: error occured in TMex9EffectNode](event.call: error occured in TMex9EffectNode): Zugriffsverletzung bei Adresse 00612EEE in Modul ‘vvvv.exe’. Lesen von Adresse 00000000
Everytime I change the values of the spread.

EDIT
I’ve just noticed That I didnt actually connect the map to the rest of the patch, it seems to have stopped the MAX Float and added the above error in its place?

eDIT 2

It was still happening with the map…
It seems to be within Damper, I’ve replaced with linear and it seems to work, I’ll report back after more testing…
Still getting that error message above though

Same thing for me, i regularly see maxfloat on dampers. It’s on a patch where there’s a lot of dampers and min nodes, all connected on the outputs of a fft4. When my render produces artifacts bugs, I have to search which damper is bugging… Usually, I fix the problem by deleting the node and re-creating it, but it rebug some minutes after. The bug appeared after the 6th or 7th damper i created. Is it an overload of fft damped data?
Help Cat !!!

what version of vvvv do you use, and is your mainloop set to Filtered or Raw?

In my case I use beta 12 and my mainloop is set to filtered.

12 and filtered for me too.
IS that effect error generic .fx file problem again?
I’ve seperated all my techniques into seperate fx files now, to get around the enum bug, can you guys still not recreate this?
Maybe I should email you this patch?

@cat i doubt the enum on .fx files problem is related. i do actually have a patch lying around that is supposed to demonstrated the bug. just didn’t have the time yet to dig into it.

i also noticed a lot of strange juddering of dampers with beta 12 and mainloop set to filtered - so i needed to set it back to raw, which of course shows all the traditional judder.

so the question is whether any cat or aze can confirm that with mainloop set to raw they don’t get those floatoverflows?

I dont seem to have experienced them again yet, I’ll report in if I do, if not you can assume that its filtered thats causing the problem!

I’m gona try in raw for confirming that (I’m not on my computer here, I have no internet at home.) I’ll tell you monday.

No bugs at all, in raw as in filtered… will tell when I’ll have more time.

MaxFloat on Damper output. Appeared also when i used the Oscillator node instead of Damper. It is the only Damper (Osc) node in this patch. When I connect a new Damper it’s fine, no prob. MaxFloat appears only after restarting/loading the patch.
I use beta21.
Somebody can help/explain here?
Thanks a lot!
Cheers
A

plattenrotation04-weimar-reb02_2009.05.25-14.51.59.jpg (113.5 kB)

Bump!
Just playing with an oscillator, and a damper, both are giving out spurious max floats…
But when I try a simpler patch, all is fine…

All but newton and linearfilter seem to exhibit this, there are some feedback loops going on but nothing too involved…

should be fixed in latest alpha