Forum

Main Patch Window Gone

Hello all,
I my main window (the window to do patching in) seems to be malfuntioning. I do see the output screen of the patches but I have somehow lost accesss to the main patching window.

This behavior is the same even when I try to use the older verion ( like 8 ). I have the latest ATI driver and DX installed. My card is a ATI 9600 it has supports 1 NTSC and 1 Moniter it is connected to the AGP slot. I am using XPSP2.

The patches seem to run fine I just cant accesss my parameters to controll them. Basically when I start the program the win “main” window shrings and stays hidden the whole session. Does that make any sense or sound familliar?

Best Regards,
JS

you seem to have hidden your last window. unfortunatly you´d need a windows to Press Alt+R or select “Show Root” from the main menu.

So while your patch is running, double click on any .v4p file to open a patch. then use this patch window to do the “show root” command.

i agree there should be a warning dialog before closing the last window.

Hello oschatz
No that doesnt seem to make any difference
at all. When the application start the main window seems
to shrink. THe DX window will play the patch I just cant
work the root ( the whole point to using VVVV for me )

Anyway I have completely unstalled and reinstalled my ATI
driver as well as Direct X. It was useless same problem.
I then thought maby a compatibillity problem so I got rid
many application that I thought might be directly related
such as window blinds, and a Mac OSX luancer bar
( for windows ) as they might be taking a higher priority
and be brought to front before the VVVV UI gets a chance
to launch. Still nothing. I am using service pack 2 and
direct X 9c if that of any relavance, and yes I reinstalled
my ati drivers that I had when it did work on machine. I
also was using service pack 1 at the time.

I also thought to reboot in safe mode it seem vvvv dint run
at all ( problably due to lack of DX9 drivers ). Since it
was a window problem I am now going to test various versions
of DIrect X one thing I did note was that if you type
“dxdiag.exe” into run it does a DX diagnostic it seems
everything was peechy. Im really baffeled why the root
window is staying closed.

Is there a preference file somewhere in my system I can
erase?

you can uninstall vvvv and delete all prefs (close to none) with the uninstall.exe in the vvvv directory.

i dont suspect a graphic card driver issue, as your animation seems to run perfect. does this happen with all patches or just specific patches?

in case it happens only with some patches:
please open the suspected root patch file with WordPad or an ASCII editor like UltraEdit (do not use Notepad)

patches are XML files with a quite simple structure.
check the third line of your patch. It should say something like
(BOUNDS height=“8130” left=“120” top=“120” type=“Window” width=“4710”)
This defines the position and visibility of the patch window.

check if the values for “top” and “left” look like reasonable pixel positions. try entering 0 if in doubt

also check if “type” is set to “Window” and not “Hidden”

Oschatz,
Thanks for the information. I agree XML system
is very easy to follow. I knew using Hyperion3D would
come in handy one day :)

Unfortunately this is not the problem. The patches run
smoothly indeed. The Root window is not still not
visable. I suspect that there is a glitch somewhere
in my system that is forcing the window into non
visabillity. Its only a theory but it may be the
Built in security or a past install of virus software
I once had installed ( Spybot search and destroy
teatimer perhaps? ) I cant be sure really. I will try
searching through my registery for VVVV and completly
remove any known traces of it then or file it may
write to the registry as a users preference. Then
I will restart it again. BTW. I also created another
user for my system and that dint work either. It
appears to be global issue that affects all users.
Im sure its an application conflict. IT would
help to know if is a service pack 2 issue. I have
used it in a SP1 enviorment for XP and had no
problems. I want this to work so of course
I will solve this as best I can, not to sound corny
but I love VVVV and I will not give up resolving this
issue.

Please let me know if you can think of anymore ideas
before I go through life changes like this :)

Still trying,
JS

vvvv uses only Args.txt for storing user settings. There are no hidden registry preferences somewhere. uninstall.exe is supposed to remove all possible traces.

we never experienced any incompatibilities with certain windows service pack. i am also not aware of incompatibilities (or even reasons for incompatibilities) with Spybot s&d or virus checkers in general.

there is one component called AddFlow3.ocx in your bin folder. vvvv registers this component to be able to run the GUI. if some other software is using other versions of the same component there might be compatibility issues. please let us know if you find any traces of an AddFlow3.ocx in your registry after you uninstalled vvvv

do you have a multimonitor system?

ja. and one other thing to test. if you delete the file Args.txt in vvvvs root folder and doubleclick vvvv.exe afterwards. do you get an empty patch window? if not it should be an AddFlow problem which we had before with one user and didn’t get rid of. if i remember correctly he had 3ds-max installed that also used a version of addflow…

if you get a patch window with a plain startup of vvvv.exe it should be really only a simple “hidden window” problem.

Yes well it seema Im out of luck becuase I do
use 3D studio Max 8 and yes it does use a library
called addflow4.ocx :(

I wonder why they conflict with each other?
I dont have max launched and conflicts usually
arise when code is in memory not some dormant
library on the hardrive. ( I dont use vvvv and
Max simultaneously ) this sucks. I really wanted
to continue to use vvvv. I will see what else I can
do.

damn. but at least we seem to have identified the problem which was the same here

i don’t have any better ideas yet. do you also get the same errormessage as the other guy when trying to register AddFlow3.ocx manually like i described in the above mentioned thread?

addflow needs the following .dlls to run:

  • MFC42.DLL
  • MSVCRT.DLL
  • OLEPRO32.DLL
    is any of those missing on your machine? they should all be placed in C:\Windows\system32

hm…

Well Im going to try two other approaches. One is
creating a envioremental variable that will lead
to the lib. I will also create a standard installer
for vvvv that will register the components. If this
does not work I will try to developer of the lib
to see if he or she has any ideas. I made first
interactive project in vvvv a year of so ago using
a clever mix of computer vision and freeframe fx I
will do my best to make this work. Reinstalling a
system as complex as mine is can take a very, very,
long time. I rather work it out before I do that. Worst
come to worst I will create a new partition and install
vvvv onto that. In the meantime I will try to resolve
the issue. Thanks so much for your idea oh I check my
system and all dll’s

  • MFC42.DLL
  • MSVCRT.DLL
  • OLEPRO32.DLL

are installed. Im sure the original creater of the library
will know exactly what conflicts with his or her software best.
But I will still proceed to create the enviormental variable
and an instally tht will register the vvvv components, NUll
soft ( winamp ) has a free installer that is script based
and freely availbe.http://nsis.sourceforge.net/Main_Page
so.

Best Regards,
JS

I have completed the installer and wow it was nice to
install vvvv for a change :) What was especially cool
was the fact that the insaller recognized vvvv unstaller
as an application so It showed up in the vvvv applications
menu as well. This gives the user the option to uninstall
file assosiations with-out unstalling vvvv as expected.

The objective to creating the more formal installation was
twofold. By creating the insaller I could then have the system
see vvvv an application the the systems tool could work with
for instance file associations. Also it could now be
selected from the “select an application” and of course the
start menu.

My experiment failed and succeeded as mentioned above VVVV
was now a system recognized application ( meaning I could
select it from various XP dialog boxes ect ), yet even after
I could finally select in in file assosciations and made a
assocsiation between vvvv and the AddFlow3.ocx lib it made
no differece :( Max is still also associated with the lib
and the 3dsmax version is at version 4 = AddFlow4.ocx the
company that produces addflow is currently at version 5.

I have checked my system registery and there are about 8 to
10 references to the addflo lib in my registery. so I will
see if the company that makes the library, Lassalle Technologies be can of some help as well. Just checked there
website quote from the addflow website referece page
http://www.lassalle.com/faq.htm:

  1. Is it compatible with the ActiveX version?

AddFlow for .NET is NOT compatible with the current ActiveX version. For instance, if you are porting an application from VB6, you will have to review almost all the code that uses AddFlow (however this is just a matter of a few hours).
If you need a strict compatibility, you can use the current ActiveX version (5.4) as a COM component in a .NET application. However we encourage you to use the .NET version which is far more powerful and easier to use.

Meaning = if 3Dstmax is using the .Net version of addflow
Im screwed, Unless I have two operating systems to
keep them apart. Anyway just thought this info might be
of some help to others as well.

i have just contacted lassalle tech about that issue. will let you know as soon as i get an answer.

Joreg,
Thanks so much for your help Joreg, I will await
the response as well.

Best Regards
Jerome

bad news. they’ve never heard of such an incompatibility and have no idea what to do.

three things to test:

  • can you open a command line, navigate to …\vvvv33beta11.1\bin and type: “regsvr32 AddFlow3.ocx” does that give an error? which?
  • go to http://www.softlookup.com/download.asp?id=23291 and get the official AddFlow3 download, install it and run the sample applications it installed. do they let you draw diagrams?
  • go to http://www.lassalle.com/download.htm and get the AddFlow5 activeX control, install it and test the sample applications. do they let you draw diagrams?

thanks for your help.

HELP!

after installing and deinstalling NVidias FXcomposer Beta 11.1 and Beta 10 show same Symptoms (no Patch Window, no possibility to get one with ALT-R)

Beta 9.2 and 9.10 on the other hand are starting as usual.

i don’t know if there is a coincidence with FXcomposer or perhaps with the patch i wanted to open.
when i tried start the attached root patch with 11.1 vvvvhung up.
and in the following i wasn’t able to see any patch windows as described.

ah, vvvvorum attachment didn’t …

so take that:
http://vvvv.org/tiki-download_file.php?fileId=919

be careful. my 11.1 didn’t work anymore since starting this

the patch opens fine here apart from some missing kallemodules. so i don’t think it is the patch.

schaisn.

if you open beta11.1 plain. without any patch. without args.txt you get no patch-window?

but you get one with 9.10?

if you open beta11.1 plain. without any patch. without args.txt you get no patch-window?

but you get one with 9.10?

yes. confirmed.

9.2 and 9.10 work,

doesn’t.

komisch kale.

tu mal alle \modules \freeframes und \effects aus den directories unter \beta11.1

ausserdem kannst du mal alle .ax aus dem \bin tun.

gehts dann?

du sagst ausserdem: wenn du einen patch mit renderer startest geht der renderer auf und rendert, aber kein patch? richtig?

as jou wrote:

i removed
/modules
/effects
/freeframe
and the .ax form /bin

no.
same as it was.


2nd thing:

no. renderer doesn’t open, has to be “in-a-box” (ALT-2)

the patch opens, thats all. it doesn’t work.