Losing effects


I have a problem with this beautiful software: previously the effects were working, now no more. (beta29.2 32bit - win8)

Like: if open a new patch and i “left doubleclick”, type camera, i miss the camera (transform softimage). But if i open a patch i have made previously that contains the (transform softimage) camera, is possible to create new cameras of that kind(second screenshot)… it like my patch became a sort of library.

In a previous post (vvvv on parallels8) i wrote about issues on the effects…
now on the my win machine, even if i use the 32bit and even if this morning everithing was ok, now the effects don’t work.
So now if i open the sphere help the fx are red.

I can’t understand why it happens.
Can you help me again? :)

i’m still tring to fix it.
Nothing changed by deleting and re-installing vvvv beta29.2 32bit.

I’ll try with 64 bit now: since it wasn’t working before, now it should do its job

maybe i figured it out:

I installed beta29 x64 - sphere( my reference node) and camera transform softimage were inside the list

After i put the addons and overwrite the nodebrowser.xml they disapper…
so my issues are caused by adding the addons, but it sounds lame.

i will update when i solve it, but if you have any advice, please… i’m going crazy!

ok, i really think the problem is me overwriting “nodebrowser.xml”.
the original is 1,4mb and the “addons” one is 679kb.

Is it possible to merge the two .xml intead of overwriting?
Have you ever had this problem?

many thanks, now i would need an answer if you have one…

i’m just guessing here, but do you by any chance have expanded the vvvv distribution archives with the windows explorer builtin zip archive handling function? if so, you should definitely try another way. (e.g. 7zip)
if the problem remains try starting vvvv from commandline with /logstartup and post the log here.

good luck ;)

thank you m4d!

i did use standard win extractor… now i tried with winrar and 7zip and the size of “addons” nodelist.xml increased to 1mb!

but it’s still not working. btw we have a responsable now.

please, can you tell me your nodelist.xml size?

this is the startup log:

17:39:46.286 everything you know is wrong
17:39:46.287 Adding lib\thirdparty\x86 to PATH.
17:39:46.298 creating SplashScreen
17:39:46.307 creating GClock
17:39:46.322 creating GMainloop
17:39:46.323 creating GLog
17:39:46.325 creating GApplication
17:39:46.326 creating GGlobals
17:39:46.333 creating GNodeFactory
17:39:46.334 creating Gex9Base
17:39:46.351 Direct3D9 initialized.
17:39:46.390 ExceptionDialog is disabled. Start vvvv with /showexceptions to enable it.
17:39:46.414 enumeratig Game Devices…
17:39:46.420 found Game Devices:
17:39:46.422 enumerating Midi Input Ports…
17:39:46.424 found Midi Input Ports: “TouchOSC Bridge”
17:39:46.426 enumerating Midi Output Ports…
17:39:46.428 found Midi Output Ports: “Microsoft GS Wavetable Synth”,“TouchOSC Bridge”
17:39:46.433 enumeratig TAPI Devices…
17:39:46.435 found TAPI devices:
17:39:46.439 enumeratig Audio Renderer Devices…
17:39:46.447 found Audio Renderer Devices: “Speakers (High Definition Audio Device)”,“Default DirectSound Device”,“Default WaveOut Device”,“DirectSound: Speakers (High Definition Audio Device)”
17:39:46.450 enumeratig Midi Renderer Devices…
17:39:46.453 found Midi Renderer Devices: “Default MidiOut Device”,“Microsoft GS Wavetable Synth”,“TouchOSC Bridge”
17:39:46.455 enumeratig External Renderer Devices…
17:39:46.457 found External Renderer Devices:
17:39:46.460 enumeratig Audio Input Devices…
17:39:46.463 found Audio Input Devices: “Microphone (High Definition Audio Device)”
17:39:46.465 enumeratig Video Input Devices…
17:39:46.471 found Video Input Devices: “Integrated Webcam”
17:39:46.493 creating MainForm
17:39:46.538 creating AddonHost
17:39:47.340 creating NodeBrowser, WindowSwitcher, Kommunikator
17:39:47.346 creating HIDDeviceController
17:39:47.351 scanning for Externals
17:39:48.497 vvvv is up and running


first: there is no nodebrowser.xml, i assume you’re talking of nodelist.xml
second: both need to be there separately, no need to merge, they are in different directories!

your layout should look like this:

see? you just copy the \addonpack directory (which is in the .zip you download) into your vvvv-dir. that should be it.

siiiiii! grazie!!

thank you so much joreg… you really deserve a couple of beers